Can't uncheck proposed or usupported boxes in Kubuntu updates sorftware sources

Bug #819793 reported by Rob Davies on 2011-08-02
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Philip Muškovac
Oneiric
Medium
Unassigned

Bug Description

Other people having a similar problem:

http://ubuntuforums.org/showthread.php?t=1816045
http://ubuntuforums.org/showthread.php?t=1788688

In KPackageKit I can't uncheck the 'Proposed updates' or the 'Unsupported updates' boxes in the 'Kubuntu updates' section of the 'Updates' tab of the 'Software Sources' window (brought up by clicking on the 'Edit Origins' button in the 'Settings' tab of 'KPackageKit').

A workaround is to use the gtk version of software-properties. On the same screen, the boxes CAN be unchecked, and the package can then be uninstalled.

I'm using 64-bit Kubuntu 11.04 if that helps, though I think the bug report should include those details.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-properties-kde 0.80.9
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Aug 2 12:25:14 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Rob Davies (megamasha-s) wrote :
Philip Muškovac (yofel) wrote :

Looking into this.

Changed in software-properties (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
status: New → Confirmed
Philip Muškovac (yofel) wrote :

Seems like you now need to pass template.name instead of template to disable_child_source()

Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

I merged this into the bzr+ssh://bazaar.launchpad.net/~ubuntu-core-dev/software-properties/oneiric branch and it will be part of the next SRU upload.

Changed in software-properties (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → Medium

Hello Rob, or anyone else affected,

Accepted software-properties into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-properties (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Rob Davies (robert-m-davies) wrote :

Tested.
Works for me.
Using software properties (kde) I enabled proposed updates with the checkbox.
I checked I was still unable to uncheck it. (the bug WAS still there)
I found the appropriate proposed update and installed it.
Now I am able to uncheck the box - it seems to have been fixed.

Thank you!

Rob

Philip Muškovac (yofel) on 2011-11-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.81.13.1

---------------
software-properties (0.81.13.1) oneiric-proposed; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - add missing build-depends to dh-translations

  [ Philip Muskovac ]
  * lp:~yofel/software-properties/lp-819793:
    - Fix for bug 819793 as disable_child_source() now need the template
      name as parameter, not the template itself )LP: #819793

  [ Robert Roth ]
  * Fix warnings logged to terminal about inexistent handlers by checking
    if the handlers exist
  * Reset the popcon checkbox value if changed, but auth failed (LP: #874759)
  * Apt-add-repository --remove changed to also remove the debsrc
    line (LP: #838507)
  * Update the manpage of apt-add-repository with the available
    options. (LP: #697546)
  * Reset the text on the mirror testing dialog after closing/canceling
    it (LP: #875679)
  * Unicode encode PPA description and displaynam to avoid
    UnicodeDecodeErrors (LP: #827355)
  * Do not expand the server combobox (LP: #875131)

software-properties (0.81.13) oneiric-proposed; urgency=low

  * lp:~kelemeng/software-properties/bug853231:
    - Build with dh_translations, to localize the .policy file at
      runtime. LP: #853231
    - Add missing files to POTFILES.in (LP: #853231)
      Many thanks to Gabor Kelemen
 -- Michael Vogt <email address hidden> Thu, 20 Oct 2011 13:46:08 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Changed in software-properties (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers