add-apt-repository and ppa-purge can't be used repeatedly

Bug #801133 reported by David Henningsson on 2011-06-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ppa-purge (Ubuntu)
Undecided
Unassigned
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
sudo add-apt-repository ppa:ubuntu-audio-dev/pulse-testing
sudo ppa-purge ppa:ubuntu-audio-dev/pulse-testing
sudo add-apt-repository ppa:ubuntu-audio-dev/pulse-testing

The repository is not re-added in the third step.

Btw, wouldn't it make sense to have ppa-purge and add-apt-repository in the same package as they are, in a sense, their opposites?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-software-properties 0.80.9
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Jun 23 14:41:21 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110322.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=sv_SE:en
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

David Henningsson (diwic) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ppa-purge (Ubuntu):
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: New → Confirmed
Paul Dumais (paul-unstate) wrote :

I was able to work around by opening the ubuntu software centre, then choosing Edit->Software Sources from the menu. Then I selected the boxes next to the software sources that I had previously tried to add. Click close. Then do sudo apt-get update.

Tim Lunn (darkxst) wrote :

This seems to no longer be an issue

Changed in software-properties (Ubuntu):
status: Confirmed → Invalid
Changed in ppa-purge (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers