add-apt-repository(add-ppa-repository(?)) leaves garbage in xorg-edgers-ppa-maverick.list

Bug #640784 reported by Wolfgang Kufner on 2010-09-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

After having run ppa-purge xorg-edgers I have this in /etc/apt/sources.list.d/xorg-edgers-ppa-maverick.list:
# deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu maverick main
# deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu maverick main

If I then try to reenable xorg-edgers by running sudo add-ppa-repository ppa:xorg-edgers/ppa I get this in that file:
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu maverick main
deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu maverick main
ain

I have to remove the "ain" by hand to get apt-get update to work.

Gerwin Verhoef (haxoid) wrote :

I can second this.

Terminal output:

gerwin@Nidavellir:~$ sudo apt-get update
E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/erik-b-andersen-rgba-gtk-maverick.list
E: The list of sources could not be read.

Osmo Laitinen (osmo-laitinen) wrote :

Same problem here while testing with some ppa packages.

This should be quite straightforward and fast to fix, but still nothing has happened over 2 months...

I do not have an add-ppa-repository, at least not anymore. What I have now is add-apt-repository and that works fine. Closing...

Changed in software-properties (Ubuntu):
status: New → Fix Released
YannUbuntu (yannubuntu) wrote :

For information, this bug was certainly a duplicate of Bug #789859

V字龍(Vdragon) (vdragon) wrote :

No it DOESN'T works fine
wondering if add-ppa-repository really exist (LOL)

summary: - add-ppa-repository leaves garbage in xorg-edgers-ppa-maverick.list
+ add-apt-repository(add-ppa-repository(?)) leaves garbage in xorg-edgers-
+ ppa-maverick.list
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers