Hide 'Software Sources' from the System > Administration menu

Bug #624072 reported by Vish on 2010-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Wishlist
Mohamed Amine Ilidrissi
software-properties (Ubuntu)
Wishlist
Mohamed Amine Ilidrissi

Bug Description

Hide 'Software Sources' from the System > Administration menu

When making changes in Software Sources, it always triggers synaptic or similar to complete the apt-update.

It would be better to hide it from the menu, and be allowed to be brought up from the respective applications alone [USC/Synaptic/Update Manager]

A user is most likely bound to think about making changes to 'Sources' [from a GUI] from either of these GUI applications.
Also, Reduces the number of [updates/software related]menu items in the Administration menu by one

Related branches

Changed in software-properties (Ubuntu):
status: New → In Progress
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
Vish (vish) on 2010-08-25
Changed in software-properties (Ubuntu):
importance: Undecided → Wishlist
Scott Ritchie (scottritchie) wrote :

I'm not sure I agree with this change at all, my users make heavy use of this being easily accessible. The directions at http://www.winehq.org/download/deb, for instance, would need to be more involved.

Have you user tested this? Have you seen users going to Software Sources unintentionally? Do you think the Administration menu too crowded?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.76.2

---------------
software-properties (0.76.2) maverick; urgency=low

  [ Michael Vogt ]
  * fix ftbfs

  [ Mohamed Amine IL Idrissi ]
  * data/software-properties-gtk.desktop.in: Menu entry is now hidden
    (LP: #624072)
 -- Michael Vogt <email address hidden> Wed, 25 Aug 2010 20:19:47 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Vish (vish) on 2010-08-25
Changed in hundredpapercuts:
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
importance: Undecided → Wishlist
status: New → Fix Released
Vish (vish) wrote :

Scott, Once the user adds ppa for wine, how does the user install/update wine?
Doesnt the user have to then bring up Synaptic or USC / update manager ?
Instead we are reducing twice the action user requires and making the sources akin to 'Preferences' we see every other application but instead for softwares here.

Rather than making Software Sources feel like a separate entity. They are now living as a preferences menu.

Scott Ritchie (scottritchie) wrote :

Vish: if you look at the link, they install wine1.3 with an apt-url link. If they already had Wine installed, update manager would upgrade it for them.

Now with this change we've added an extra step, and I'm not sure it's helpful.

Vish (vish) wrote :

Scott, No,Update manager does not pop-up on its own. [ I'v tried that again, even now]
We need to remember that the default update-manager behavior is to not prompt for updates everyday.
So, if a non-security update is available it wont automatically pop-up until 7days have passed since the last update.
There are so many ways[ex:apt-pinning] for update manager to not appear after we add a ppa. Moving it as a preferences avoids those scenarios. [for apt-pinning, we need to use synaptic , maybe something that needs to be looked into for USC as well.]

Matthew Paul Thomas (mpt) wrote :

Scott, it looks to me as if the instructions will need one changed step and one extra step, both of which are compatible with previous versions of Ubuntu.

The changed step is that "Open the Software Sources menu by going to System->Administration->Software Sources" should become "Open Update Manager (System > Administration > Update Manager), and click Settings".

The extra step is at the end: "Click 'Check'."

Sara M (jibjibak) on 2010-08-26
Changed in hundredpapercuts:
status: Fix Released → Incomplete
status: Incomplete → Fix Released
Vish (vish) wrote :

Apparently the fix did not work! , The menu item is still visible in System > Administration. Re-opening bug

Changed in software-properties (Ubuntu):
status: Fix Released → Triaged
Changed in hundredpapercuts:
status: Fix Released → In Progress
Vish (vish) wrote :

The problem was True was set with a capital ! :)
Changing :
NoDisplay=True

to

NoDisplay=true

Works..!

[Thanks to kiwinote for pointing this out.]

@Mohamed Amine IL Idrissi , new merge? ;)

@Vish: of course :)

Changed in software-properties (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.76.5

---------------
software-properties (0.76.5) maverick; urgency=low

  [ Mohamed Amine IL Idrissi ]
  * data/software-properties-gtk.desktop.in: desktop file is now really
    hidden (LP: #624072)
 -- Michael Vogt <email address hidden> Tue, 07 Sep 2010 15:23:11 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Vish (vish) wrote :

Confirmed , its truly gone now! ;-)

Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers