If deb-src lines are going to be added automatically, they shouldn't be enabled and slowing down apt-get update.

Bug #621977 reported by Eric Appleman on 2010-08-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Wishlist
Andrea Corbellini

Bug Description

Updating sources on my machine takes long enough as it is.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-properties-gtk 0.76
ProcVersionSignature: Ubuntu 2.6.35-16.22-genusername 2.6.35.2
Uname: Linux 2.6.35-16-generic i686
Architecture: i386
Date: Sat Aug 21 17:03:18 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties

Related branches

Eric Appleman (erappleman) wrote :
Vallery Lancey (muscovy) wrote :

You'll have to ask a developer who's worked on apt or something, but I don't know if the sources do slow it down. It's not like sources have all have separate control file data and so on.

Eric Appleman (erappleman) wrote :

I'm pretty sure it slows it down since the number of sources to be downloaded increases if deb-src repos are enabled.

Eric, thanks for your bug report. You are right, and I agree that manually deleting/commenting the deb-src lines can be annoying. What if I add a command line option to enable the addition of deb-src entries? Does it seems a good solution for you?

Eric Appleman (erappleman) wrote :

Even if the deb-src line was included automatically yet disabled if one adds a PPA through software-properties-gtk, I think your average user would get confused by the extra entries.

Making deb-src addition a command line flag or toggle for add-apt-repository would be a good compromise.

Darik Horn (dajhorn) wrote :

See the discussion in Bug #399711. The deb-src line is being added as a design choice.

Matt Fischer (mfisch) on 2012-11-14
Changed in software-properties (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrea Corbellini (andrea.corbellini)
Michael Terry (mterry) on 2013-01-24
Changed in software-properties (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.14.1

---------------
software-properties (0.92.14.1) raring; urgency=low

  * Build-depend on python-setuptools.
 -- Matthias Klose <email address hidden> Fri, 15 Feb 2013 20:01:57 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers