Typo in --help of apt-add-repository

Bug #586790 reported by Reuben Thomas on 2010-05-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Low
Unassigned

Bug Description

"synatax" -> "syntax"

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: python-software-properties 0.75.10
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Fri May 28 13:02:16 2010
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
SourcePackage: software-properties

Related branches

Reuben Thomas (rrt) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Someone please mark this bug as triaged and of low importance.

Changed in software-properties (Ubuntu):
status: New → Confirmed
tags: added: typo
Changed in software-properties (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low

Whilst there is a man page at /debian/manpages/add-apt-repository.1 the documentation in the script itself is poor, so I wrote a patch. It is worth noting that the man page only works if you go

man add-apt-repository

but not

man apt-add-repository

Since both names work from the command-line, and sources of information on the web seem to be evenly quoting either, the man page should really also work with the latter invocation as well as the former. This is really only a minor oversight.

tags: added: patch
Michael Vogt (mvo) wrote :

Thanks Daniel and Jonathan! I commited it to bzr and it will be part of the next upload.

Changed in software-properties (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.76

---------------
software-properties (0.76) maverick; urgency=low

  [ Jonathan Harker ]
  * Improve documentation for apt-add-repository (LP: #586790)

  [ mac9416 ]
  * Fixed bug LP: #446216: added --remove option to add-apt-reporitory.
  * Fixed Bug LP: #579669 which points out that add-apt-repository will
    create a sources.list.d file with illegal characters
    if there are illegal characters in a PPA name

  [ Andrea Corbellini ]
  * Automatically create a deb-src line when adding a new repository
    (LP: 399711)

  [ Michael Vogt ]
  * add test for LP: #579669 and use re.sub() instead of urllib.quote()
  * merged lp:~alexzak/software-properties/fixes, many thanks

  [ Erik B. Andersen ]
  * Fixed depreciation warnings

  [ Brandon Tomlinson ]
  * Altered data/glade/main.glade Put the bottom buttons in a button box
    to make the buttons assume the correct width (LP: #515990)
 -- Michael Vogt <email address hidden> Fri, 13 Aug 2010 17:38:45 +0200

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers