Can not open the Edit Software Sources window from KPackageKit

Bug #545927 reported by RussianNeuroMancer on 2010-03-24
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by lex

Bug Description

Binary package hint: kpackagekit

Problem exactly like here https://bugs.launchpad.net/ubuntu/+source/kpackagekit/+bug/466206 but in Kubuntu 10.04 with KDE 4.4.1.

Log of kdesudo software-properties-kde:
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 128, in __init__
    self.init_distro()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 209, in init_distro
    text = _("%s updates") % self.distro.id
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 24 19:36:04 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Отказано в доступе: '/var/log/installer/media-info'
Package: kpackagekit 0.5.4-0ubuntu3
ProcEnviron:
 LANGUAGE=ru_RU:ru:en_GB:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: kpackagekit
Uname: Linux 2.6.32-17-generic x86_64

Related branches

affects: kpackagekit (Ubuntu) → software-properties (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.9

---------------
software-properties (0.75.9) lucid; urgency=low

  * [KDE] Fix crash caused by translations containing distro name (LP: #545927)
 -- Amichai Rothman <email address hidden> Mon, 29 Mar 2010 02:34:40 +0300

Changed in software-properties (Ubuntu):
status: New → Fix Released

kdesudo software-properties-kde
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 67, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 90, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 538, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python2.6/dist-packages/aptsources/distro.py", line 90, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

I'm using Lucid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers