Software sources should show what is disabled

Bug #543207 reported by Micah Gersten on 2010-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be nice to see what is disabled rather than having to click edit to see it. Being unchecked already means it's disabled.

ProblemType: Bug
Architecture: amd64
Date: Sun Mar 21 01:25:42 2010
DistroRelease: Ubuntu 10.04
Package: software-properties-gtk 0.75.7
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: software-properties
Uname: Linux 2.6.32-16-generic x86_64

Micah Gersten (micahg) wrote :
Changed in software-properties (Ubuntu):
importance: Undecided → Wishlist
Michael Vogt (mvo) wrote :

This is a side effect of software-properties showing the comment by defualt and update-manager disabling the sources.list with a this comment.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2010-03-26
Changed in software-properties (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.8

---------------
software-properties (0.75.8) lucid; urgency=low

  [ Michael Vogt ]
  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - do not crash if tranient parent can not be set (LP: #83914)
  * debian/manpages/software-properties-gtk.1:
    - add man-page (thanks to Gabe Gorelick) LP: #290308
  * add-apt-repository:
    - better help output (LP: #407779)
    - do not crash if setlocale fails (LP: #467369)
  * software-properties-gtk:
    - ensure newly created ppa files are readalbe (LP: #497778)
  * data/software-properties-gtk.desktop.in:
    - fix desktop file location (thanks to Ricardo Pérez López)
      LP: #543637
  * provide apt-add-repository link (LP: #547194)
  * debian/manpages/add-apt-repository.1:
    - add man-page, thanks to Chow Loong Jin (LP: #407779)
  * fix lintian warnings
  * softwareproperties/SoftwareProperties.py:
    - show summary in addition to comment for disabled entries
      (LP: #543207)

  [ Harald Sitter ]
  * [KDE] Fix bug in I18nHelper, where it would trigger a crash if unicode()
    to UTF-8 fails. Fallback to latin1 in this case. This for example happens
    when the APT keyring contains a key with non-latin characters, which can
    happen with PPA keys, since those contain the owner's name.
 -- Michael Vogt <email address hidden> Fri, 26 Mar 2010 13:51:20 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers