Software sources window becomes inactive after refresh

Bug #357617 reported by Sebastian Haselbeck on 2009-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Michael Vogt

Bug Description

Using Jaunty as of April 7 (32bit).
When I click software sources and let it chose the best server close to me, after clicking close it naturally wants to refresh the package lists, so I let it do that. Then however, the window is being grayed out and nothing happens. A click on the close button prompts me to refresh the package lists again (which I've just done) and it is unclear whether closing anyways will render the previous refresh useless.

Thinking this might not be severe but not very "for human beings"-ish

affects: ubuntu → software-properties (Ubuntu)
Michael Vogt (mvo) wrote :

Thanks for your bugreport

I was able to reproduce the problem here.

Changed in software-properties (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75

---------------
software-properties (0.75) karmic; urgency=low

  * new helper script "add-apt-repository" that can be used to
    enable a repository from the commandline. Useful for e.g.
    'add-apt-repository ppa:gnome-desktop'
  * fix error in auto-upgrade settings when
    dpkg-reconfigure unattended-upgrades was used (LP: #387704)
  * po/zh_TW.po:
    - updated, thanks to Roy Chan (LP: #365040)
  * softwareproperties/kde/SoftwarePropertiesKDE.py:
    - do not error on cancel (LP: #364288)
    - use the SUDO_USER home instead of /root (if available)
      (LP: #364197)
    - add utf8() function and replace the custom converts to it
      (hopefully fixes LP: #362188)
    - disable "Find best server" for now, the threading crashing
      KDE
  * softwareproperties/gtk/DialogCacheOutdated.py:
    - fix incorrect wait on synaptic (LP: #357617, LP: #349639)
  * softwareproperties/SoftwareProperties.py:
    - check/ensure apt daily cron job is executable (LP: #390319)

 -- Michael Vogt <email address hidden> Tue, 14 Jul 2009 16:54:38 +0200

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released

I'm not sure this issue is actually fixed. I just encountered the same problem on a clean install of 9.10 (Karmic).

I couldn't locate a package called "software-properties", but "apt-cache showpkg software-properties-gtk" shows version 0.75.4 installed. Since the version is close to that cited in the Launchpad Janitor post, I'm guessing this is the same package that was supposed to fix the issue.

PLEASE NOTE: This behavior is observed when "Software Sources" is launched directly from the System / Administration menu, and not from the "Settings..." button within Update Manager. The Software Sources window becomes grayed out and inactive after the window for choosing the server is closed. Trying to close the grayed out Software Sources window results in a new prompt to reload the package list.

I've actually seen this behavior consistently across several previous versions of Ubuntu, so when I ran into it today I thought I'd better report it if nobody else had. Since this bug report already accurately describes the symptoms, can it be re-opened?

I've just tried this on 10.04 and I can't seem to be able to reproduce it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers