python2.6 crashed with UnicodeDecodeError in exists() with non-ascii filenames

Bug #350485 reported by jc1985 on 2009-03-28
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: python2.6

Kubuntu jaunty beta updated
python 2.6.1-1ubuntu6

when i try to import a pgp key with software-properties-kde, nothing gets imported and I have this crash

ProblemType: Crash
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 zlib1g 1:1.2.3.3.dfsg-12ubuntu2
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu3
 libc6 2.9-4ubuntu4
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/python2.6
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: python2.6-minimal 2.6.1-1ubuntu6
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/software-properties-kde --attach 52428889
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: []
SourcePackage: python2.6
Title: python2.6 crashed with UnicodeDecodeError in exists()
Uname: Linux 2.6.28-11-generic i686
UserGroups:

Related branches

jc1985 (jc1985) wrote :
affects: python2.6 (Ubuntu) → software-properties (Ubuntu)
visibility: private → public
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

I can reproduce it when trying to import "ä.gpg"

summary: - python2.6 crashed with UnicodeDecodeError in exists()
+ python2.6 crashed with UnicodeDecodeError in exists() with non-ascii
+ filenames
amichair (amichai2) wrote :

Here's a patch to fix this.

starslights (starslights) wrote :

hello amichair,

Great work, now the bug are fixed and work well :=)

best regards

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.5

---------------
software-properties (0.75.5) lucid; urgency=low

  [ Harald Sitter ]
  * KDE frontend: replace old manual listing of file endings for key import
    with mimetype based model (no need to support old stuff since it is so
    incredibly wrong... ending-wise that is)

  [ Amichai Rothman ]
  * Fix import of keys with non-ascii filename (LP: #350485)
  * Add source line input validation when adding a new source (LP: #116445)
  * Fix selected item and edit/remove button state after toggling a source
  * Fix alternate mirror selection corrupting sources.list (LP: #464707)
  * Fix selected mirror not shown in combobox (LP: #96110)
  * Fix mirror selection dialog error in non-ascii locale (LP: #96201)
  * Fix crash when modifying sources selection (LP: #102792)
  * Fix error handling when ppa key is missing (LP: #475220)
  * Improve keyboard tab order in some dialogs (LP: #464569)
  * Fix and improve mirror test and GUI (LP: #223047)
  * Fix mirror test timeout handling (LP: #456365)
  * Fix i18n, accelerators and styling on all dialogs (LP: #102773)
  * Fix utf8 in edit source dialog comments (LP: #489960)
 -- Amichai Rothman <email address hidden> Mon, 07 Dec 2009 14:46:38 +0200

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers