Intrepid fresh install, software mirror selection tree is empty

Bug #332205 reported by bugler@gmail.com on 2009-02-20
2
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Michael Vogt

Bug Description

When running the Software Sources program under System --> Administration, selecting "Other" under the mirror selection box gives an empty listing where the server listing tree usually shows up. I ran the program through the terminal and upon clicking "other", it gives this traceback:

:~$ gksu --desktop /usr/share/applications/software-properties.desktop /usr/bin/software-properties-gtk
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.5/threading.py", line 446, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.5/site-packages/softwareproperties/gtk/DialogMirror.py", line 344, in on_button_test_clicked
    rocker = test.run_full_test()
  File "/usr/lib/python2.5/site-packages/softwareproperties/gtk/DialogMirror.py", line 313, in run_full_test
    results_ping.append([0, 0, self.mirrors[random.randint(1, len(self.mirrors))]])
  File "/usr/lib/python2.5/random.py", line 215, in randint
    return self.randrange(a, b+1)
  File "/usr/lib/python2.5/random.py", line 191, in randrange
    raise ValueError, "empty range for randrange() (%d,%d, %d)" % (istart, istop, width)
ValueError: empty range for randrange() (1,1, 0)
------------------------------
Attempting to do an update at the moment, the default server is painfully slow so I'll update with the results when I receive them, I see a few python updates in there that may fix this?

System info:
Description: Ubuntu 8.10
Release: 8.10

Intrepid install from the ppc alternative desktop disk onto a Mac Pro Dual G5.
Linux 2.6.25-2-powerpc64-smp #1 SMP Tue Sep 30 16:40:22 UTC 2008 ppc64 GNU/Linux

-------------------------------------

Just got done with the python updates and restarted the machine, same error. Then I tried re-installing software-properties-gtk from synaptic, same results.

description: updated
Pedro Villavicencio (pedro) wrote :

The trace is good to be looked by a developer, however i cannot replicate the problem locally.

Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks fror your bugreport.

The crash is fixed in bzr, the fact that there are no mirrors is odd, what version of ubuntu are you using?

Could you please tell me what size the files:

/usr/share/python-apt/templates/Debian.mirrors
/usr/share/python-apt/templates/Ubuntu.mirrors

have?

Changed in software-properties (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → mvo
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.71.5

---------------
software-properties (0.71.5) jaunty; urgency=low

  * debian/control:
    - put "software-properties-kde" into the kde section
      (LP: #323556)
  * softwareproperties/SoftwareProperties.py:
    - fix crash in the way md5 from hashlib is used (LP: #346863)
  * softwareproperties/gtk/DialogMirror.py:
    - fix crash when no mirrors are available (LP: #332205)
  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - make is_seperator() more robust (LP: #335637)

 -- Michael Vogt <email address hidden> Fri, 27 Mar 2009 15:00:56 +0100

Changed in software-properties:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers