Ubuntu

Add an ISO image repository.

Reported by Joel Bryan Juliano on 2006-02-21
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Wishlist
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

Rationale

- Joelle just recently downloaded a new version of Ubuntu. However, he's really upset because he just run out of extra cdr to burn and upgrade his existing Ubuntu system. He then run synaptics and configure the repository, then he add an ISO image to the repository.

- Bryan lives from the mountain province of China, and he just recently obtained an ISO from outer-space, however, he can't figure out how to burn the ISO and he's stuck with his CD-ROM, he now just load the ISO from his hard disk and add it up in the repository.

- Juliano is a simple guy, he has a computer, and he just do simple things with it, he goes online using his P100 pesos prepaid card and a 56k modem once in a while just to check his e-mail and other social networking stuff. However, he's so devastated by the slow respond of his Ubuntu Breezy and curse the developers to hell, and start crying..., he made up his mind and said to himself "I WANT TO UPGRADE MY UBUNTU!!" 44 times, he knows it's best to upgrade to Dapper but he can't use synaptics because it would cost him P100 pesos of prepaid card to download the updates using his mere 56k modem... Instead of cursing the developers to hell, he obtain an ISO image from his friends with a USB thumbstick, and run synaptics and configured it to use the ISO as a repository. The following day, he's so happy, he committed suicide.

Synaptics Changes

- Add a link that says "Add an ISO image" in the repository configuration screen that will extract the ISO image in the /var/apt/cache/iso/dapper/ directory and automatically add it in the synaptics configuration, then upgrade the existing system.

Dennis Kaarsemaker (dennis) wrote :

For upgrading you don't need to download an ISO, you can simply let APT handle it...

For other cases where this might be useful: simply mount the iso and add the mountpoint as repository.

description: updated
Fred (eldmannen+launchpad) wrote :

He can download an ISO from here;
* http://www.ubuntu.com/getubuntu/download

Savvas Radevic (medigeek) wrote :

1. I believe that hardy and intrepid when you place in a cd, it pops up a window asking you if you want to add the cd as a repository (see attached screenshot).
2. The CD can be added even through System > Administration > Software Sources > Third-party > Add cdrom - When done, "Close" and "Reload".
3. I also think that this is the point of aptoncd: http://aptoncd.sourceforge.net/

Savvas Radevic (medigeek) wrote :

Joel, I think these solutions fulfill your wish

Changed in synaptic:
status: New → Fix Released
Savvas Radevic (medigeek) wrote :

oops, misread, my apologies

Changed in synaptic:
status: Fix Released → New
BlessedGeek (blessedgeek) wrote :

I'm on 64bit 9.04.
I want to upgrade to studio.
I just spent 2 hours downloading studio iso.

I don't want to deb the ubuntu upgrade site because that is a waste of time.
I don't want to make a dvd because that is a waste of plastic because I want my great grandchildren not have to suffer further effects of global warming from any extra plastic I use.

I want to deb the ubuntu studio iso.

I tried deb file:///media/disk/ROMs/ubuntustudio-9.10-rc-alternate-amd64.iso and
I tried deb file:////media/disk/ROMs/ubuntustudio-9.10-rc-alternate-amd64.iso and
I tried deb file://media/disk/ROMs/ubuntustudio-9.10-rc-alternate-amd64.iso
appending karmic main restricted at the end.
at add software - third party software.

OK, I'll try the silly idea that may be it would work for my current 9.04 iso.
So I deb my current 9.04 iso using various silly combinations of file://///// (whatever number of slashes just as I had with the 9.10). No it doesn't work.

The response was simply
file://media/disk/ROMs/ubuntustudio-9.10-rc-alternate-amd64.iso/Package not found.

Of course, because there is no such directory Package in any of the ubuntu installation cd iso that I have.

You cannot deb an iso!!!! Period. Full-stop. Why not? Debbing an iso is such a great idea, why not?

Rant: Now I don't trust this person's blog
http://www.zimbio.com/Linux/articles/kEIN6zMahru/Add+iso+software+repository+Ubuntu
because that is what I did above and I feel sore that people should not give advice, that does not work, on the net. Perhaps, it should work, but I don't feel leaving a comment asking why because I would need to register. Why do they make us register? I have registered for too many z*** sites already. For ubuntu i have already registered for three different sites - they should just take open ids and stop making us create logins and passwords to remember. So can someone tell me if this person's method could actually work and how?

OK, I tried another silly idea. I mounted the iso and at
add software - third party software - add cd.
Nope, it does not recognise my mounted iso as a cd.

Why doesn't ubuntu spontaneously recognise it as a cd?
Why doesn't add software sources wizard recognise a mounted point as a software source?

Some advice needed here on how to proceed, besides looking at an existent bug report, before I blow my top off. I want to deb the ubuntu studio iso.

Thanks.

Luke Orland (orluke) wrote :

BlessedGeek,
Perhaps the following link describes how to achieve you desired goal -
https://help.ubuntu.com/community/IntrepidUpgrades#AlternateUpgrade

Why don't you just install package ubuntustudio-desktop. This will install studio packages on your machine.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

As mentioned in comment 7 there is already a way to install from an iso. Mount the iso and use the file:/ URI. (man sources.list)
@BlessedGeek, you can't directly access the iso and forgot the first step of the blog post you mentioned "The first step is to mount the iso. For detailed tutorial on mounting iso in Ubuntu can be found here."
Furthermore, root need to have read access to the mounted iso. So using "archive mounter" from a user account won't work since root has no read access to the user's .gvfs directory.

An improvement could be to propose an option in software-properties to mount the iso and avoid the manual mount.
I'm affecting this report to software-properties and setting to triage.

Thanks for your help.

affects: synaptic (Ubuntu) → software-properties (Ubuntu)
Changed in software-properties (Ubuntu):
status: New → Triaged

Nevertheless, you'll have to remount the iso manually after next reboot. I'm not sure if there's a good solution there.

> As mentioned in comment 7 there is already a way to install from an iso. Mount the iso and use the file:/ URI.
It's a crutch and not a solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers