software-properties-gtk has no man page

Bug #290308 reported by Siegfried Gevatter on 2008-10-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Low
Michael Vogt

Bug Description

$ man software-properties-gtk
No manual entry for software-properties-gtk

Changed in software-properties:
importance: Undecided → Low
status: New → Confirmed
Gabe Gorelick (gabegorelick) wrote :

Still no man page in Karmic

summary: - software-properties-gtk has no manpage
+ software-properties-gtk has no man page
Gabe Gorelick (gabegorelick) wrote :

Doesn't appear to be one in Lucid source tree either, though strangely there is one for software-properties-kde.

Gabe Gorelick (gabegorelick) wrote :

patch to provide a man page for software-properties-gtk. It *should* build and install ok, assuming there's nothing fancy in the build process with man pages going on that I don't know about, though I have not actually tested it.

Michael Vogt (mvo) on 2010-03-26
Changed in software-properties (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.8

---------------
software-properties (0.75.8) lucid; urgency=low

  [ Michael Vogt ]
  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - do not crash if tranient parent can not be set (LP: #83914)
  * debian/manpages/software-properties-gtk.1:
    - add man-page (thanks to Gabe Gorelick) LP: #290308
  * add-apt-repository:
    - better help output (LP: #407779)
    - do not crash if setlocale fails (LP: #467369)
  * software-properties-gtk:
    - ensure newly created ppa files are readalbe (LP: #497778)
  * data/software-properties-gtk.desktop.in:
    - fix desktop file location (thanks to Ricardo Pérez López)
      LP: #543637
  * provide apt-add-repository link (LP: #547194)
  * debian/manpages/add-apt-repository.1:
    - add man-page, thanks to Chow Loong Jin (LP: #407779)
  * fix lintian warnings
  * softwareproperties/SoftwareProperties.py:
    - show summary in addition to comment for disabled entries
      (LP: #543207)

  [ Harald Sitter ]
  * [KDE] Fix bug in I18nHelper, where it would trigger a crash if unicode()
    to UTF-8 fails. Fallback to latin1 in this case. This for example happens
    when the APT keyring contains a key with non-latin characters, which can
    happen with PPA keys, since those contain the owner's name.
 -- Michael Vogt <email address hidden> Fri, 26 Mar 2010 13:51:20 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches