Find Best Server fails

Bug #223047 reported by Sebastian Abate on 2008-04-27
48
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Low
Unassigned

Bug Description

Kubuntu 8.04 (upgraded from 7.10 to Alpha 5, to Beta, to RC, to Final via dist-upgrade; also happens in a fresh install, tested in a VirtualBox VM)

By selecting "Find best server" in "Choose a download server" closes the dialog "Software sources" and in the terminal appears the following error:

ASSERT failure in QWidget: "Widgets must be created in the GUI thread.", file kernel/qwidget.cpp, line 959

This does not happen with synaptic (the "Find best server" option works as expected)

Related branches

Alejandro Díaz-Caro (janus) wrote :

I can confirm this bug in 64 bits.

The following is the complete output that I receive in the console (I removed the blank lines for short and added some remarks between ***):

janus@ernestina:~$ kdesudo adept_manager
passprompt
kbuildsycoca running...
DCOP Cleaning up dead connections.
kapture::PkgSystem::PkgSystem()
python
python-central
lsb-release
python-apt
python
python-central
lsb-release
python-apt
kdecore (KProcess): WARNING: _attachPty() 32
*** At this point I select "manage repositories" and receive the following ***
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
*** Selecting "Other" for server ***
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
*** Clicking "Find best server" ***
ASSERT failure in QWidget: "Widgets must be created in the GUI thread.", file kernel/qwidget.cpp, line 959
no updateTrue
*** At this point, the repositories windows closed ***
*** When I closed adept, I receive this ***
Mutex destroy failure: Dispositivo ó recurso ocupado (translation: "Device or resource busy")

Changed in adept:
status: New → Confirmed
Andrew Min (andrewmin) wrote :

I can also confirm this in a fresh Hardy install (3.5.9, not KDE4).

I can also confirm the described behaviour. The environment is Kubuntu 8.04 64-bit fresh install KDE 3.5. It was also experienced with kubuntu-desktop installed on top of Ubuntu 7.10 and subsequent upgrade.

Here is my console output (basically the same as the previous comment)
christopher@christopher-gaming-desktop:~$ sudo adept_manager
kapture::PkgSystem::PkgSystem()
Error: "/var/tmp/kdecache-christopher" is owned by uid 1000 instead of uid 0.
python
python-central
lsb-release
python-apt
python
python-central
lsb-release
python-apt
kdecore (KProcess): WARNING: _attachPty() 30
-----------------------------
clicked Adept Menu->Manage Repositories
-----------------------------
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
no updateTrue
-----------------------------
clicked Find Best Server
-----------------------------
ASSERT failure in QWidget: "Widgets must be created in the GUI thread.", file kernel/qwidget.cpp, line 959
-----------------------------
closed Adept
-----------------------------

Jonathan Thomas (echidnaman) wrote :

In Intrepid it does this:

QPainter: It is not safe to use drawTiledPixmap() outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPainter::begin: Cannot paint on a null pixmap
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 169
  Extension: 151 (RENDER)
  Minor opcode: 25 (RenderCompositeGlyphs32)
  Resource id: 0x0
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 169
  Extension: 151 (RENDER)
  Minor opcode: 25 (RenderCompositeGlyphs32)
  Resource id: 0x0

Jonathan Thomas (echidnaman) wrote :

As software-properties-kde isn't related to adept, (other than it is launched from it) I am removing the adept tags.

Changed in software-properties (Ubuntu):
importance: Undecided → Low
Jimhu (huyiwei) wrote :

Still not working in Jaunty RC...

Marco Costantini (costanti) wrote :

also in Kubuntu karmic 9.10 alpha 2 live CD

ubuntu@ubuntu:~$ sudo software-properties-kde

Error: "/var/tmp/kdecache-ubuntu" is owned by uid 999 instead of uid 0.
Error: "/tmp/kde-ubuntu" is owned by uid 999 instead of uid 0.
QObject::setParent: Cannot set parent, new parent is in a different thread
QObject::installEventFilter(): Cannot filter events for objects in a different thread.
QObject::installEventFilter(): Cannot filter events for objects in a different thread.
QObject::installEventFilter(): Cannot filter events for objects in a different thread.
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPainter::begin: Cannot paint on a null pixmap
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPainter::begin: Cannot paint on a null pixmap
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPainter::begin: Cannot paint on a null pixmap
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPixmap: It is not safe to use pixmaps outside the GUI thread
QPainter::begin: Cannot paint on a null pixmap
QPixmap: It is not safe to use pixmaps outside the GUI thread
QObject::installEventFilter(): Cannot filter events for objects in a different thread.
software-properties-kde: Fatal IO error: client killed
Segmentation fault (core dumped)
ubuntu@ubuntu:~$

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.5

---------------
software-properties (0.75.5) lucid; urgency=low

  [ Harald Sitter ]
  * KDE frontend: replace old manual listing of file endings for key import
    with mimetype based model (no need to support old stuff since it is so
    incredibly wrong... ending-wise that is)

  [ Amichai Rothman ]
  * Fix import of keys with non-ascii filename (LP: #350485)
  * Add source line input validation when adding a new source (LP: #116445)
  * Fix selected item and edit/remove button state after toggling a source
  * Fix alternate mirror selection corrupting sources.list (LP: #464707)
  * Fix selected mirror not shown in combobox (LP: #96110)
  * Fix mirror selection dialog error in non-ascii locale (LP: #96201)
  * Fix crash when modifying sources selection (LP: #102792)
  * Fix error handling when ppa key is missing (LP: #475220)
  * Improve keyboard tab order in some dialogs (LP: #464569)
  * Fix and improve mirror test and GUI (LP: #223047)
  * Fix mirror test timeout handling (LP: #456365)
  * Fix i18n, accelerators and styling on all dialogs (LP: #102773)
  * Fix utf8 in edit source dialog comments (LP: #489960)
 -- Amichai Rothman <email address hidden> Mon, 07 Dec 2009 14:46:38 +0200

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers