software-properties-gtk crashed with IOError in save()

Bug #221667 reported by Matthew Lancey on 2008-04-25
54
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

Thanks

ProblemType: Crash
Architecture: i386
Date: Fri Apr 25 13:35:57 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/software-properties-gtk
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: software-properties-gtk 0.63ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-properties-gtk
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-properties-gtk']
SourcePackage: software-properties
Title: software-properties-gtk crashed with IOError in save()
Uname: Linux 2.6.24-16-generic i686
UserGroups:

Related branches

Matthew Lancey (infinitejones) wrote :
Changed in software-properties:
importance: Undecided → Medium
tdflanders (thomasdelbeke) wrote :

Hi, this bug clearly is not fixed yet, since I keep on experiencing it over and over again. Thank you, Thomas.

System info:

Acer Aspire 9410-4933
Intel Core Duo processor T2450
(2.0 GHz, 533 MHz FSB, 2MB L2 cache)
17" WXGA+ Acer CrystalBrite LCD
Intel Graphics Media Accelerator 950
160GB HDD
DVD-Super Multi double layer
(support DVD+-R Double Layer/DVD+-RW)
1GB DDR2
802.11a/b/g wireless LAN

thomas@thomas-laptop:~$ lsb_release -rd ; uname -a ; apt-cache policy linux-headers-generic linux-image-generic linux linux-source-2.6.27 linux-restricted-modules synaptic apport-gtk software-properties-gtk
Description: Ubuntu intrepid (development branch)
Release: 8.10
Linux thomas-laptop 2.6.26-4-generic #1 SMP Mon Jul 14 18:39:53 UTC 2008 i686 GNU/Linux
linux-headers-generic:
  Installed: 2.6.27.2.2
  Candidate: 2.6.27.2.2
  Version table:
 *** 2.6.27.2.2 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
linux-image-generic:
  Installed: 2.6.27.2.2
  Candidate: 2.6.27.2.2
  Version table:
 *** 2.6.27.2.2 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
linux:
  Installed: 2.6.27.2.2
  Candidate: 2.6.27.2.2
  Version table:
 *** 2.6.27.2.2 0
        500 http://gb.archive.ubuntu.com intrepid/restricted Packages
        100 /var/lib/dpkg/status
linux-source-2.6.27:
  Installed: 2.6.27-2.3
  Candidate: 2.6.27-2.3
  Version table:
 *** 2.6.27-2.3 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
linux-restricted-modules:
  Installed: 2.6.27.2.2
  Candidate: 2.6.27.2.2
  Version table:
 *** 2.6.27.2.2 0
        500 http://gb.archive.ubuntu.com intrepid/restricted Packages
        100 /var/lib/dpkg/status
synaptic:
  Installed: 0.62.1ubuntu8
  Candidate: 0.62.1ubuntu8
  Version table:
 *** 0.62.1ubuntu8 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
apport-gtk:
  Installed: 0.114
  Candidate: 0.114
  Version table:
 *** 0.114 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
software-properties-gtk:
  Installed: 0.65ubuntu1
  Candidate: 0.65ubuntu1
  Version table:
 *** 0.65ubuntu1 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
thomas@thomas-laptop:~$

tdflanders (thomasdelbeke) wrote :
Pedro Villavicencio (pedro) wrote :

setting this to confirmed trace is good and there's a good quantity of duplicates.

Changed in software-properties (Ubuntu):
status: New → Confirmed
amichair (amichai2) wrote :

As duplicate bug #461125shows, this happens also in kde, originating in a different action. Looks like a bug in the common backend sources list handling.

amichair (amichai2) wrote :

I found how to recreate this bug (it's pretty easy when you have the code to look at :-) ) :

1. open software-properties (gtk/kde).
2. select 'add CD-ROM' button (with no CD in the drive).
3. wait for an error message box (because there's no CD in the drive).
4. press OK to dismiss the message box.
5. At this point, the app is pointing to an invalid temporary sources list, so any action that modifies the sources list will result in this error. For example, go to the first tab, and toggle any component - the error is reproduced.

(if anyone sees this happen when there's no CD-ROM actions involved, please speak up!)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.6

---------------
software-properties (0.75.6) lucid; urgency=low

  * Fix cdrom progress bar popping up after being canceled (LP: #496257)
  * Fix adding cdrom source to top of sources list (LP: #162395)
  * Fix instability after failed cdrom addition (LP: #221667)
  * Fix focus in add source dialog
 -- Amichai Rothman <email address hidden> Tue, 22 Dec 2009 17:29:46 +0000

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers