software-properties-gtk crashed with AttributeError in __init__(): 'ElementTree' object has no attribute 'getiterator'

Bug #1909918 reported by C Schilder
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

lsb_release -rd
Description: Ubuntu Hirsute Hippo (development branch)
Release: 21.04
apt-cache policy software-properties-gtk
software-properties-gtk:
  Installed: 0.99.5
  Candidate: 0.99.5
  Version table:
 *** 0.99.5 500
        500 http://nl.archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 21.04
Package: software-properties-gtk 0.99.5
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu55
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: GNOME
Date: Sun Jan 3 17:37:55 2021
ExecutablePath: /usr/bin/software-properties-gtk
InstallationDate: Installed on 2021-01-03 (0 days ago)
InstallationMedia: Ubuntu-Server 21.04 "Hirsute Hippo" - Alpha amd64 (20201231)
InterpreterPath: /usr/bin/python3.9
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/software-properties-gtk
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Python3Details: /usr/bin/python3.9, Python 3.9.1, python3-minimal, 3.9.0-3ubuntu1
PythonArgs: ['/usr/bin/software-properties-gtk']
PythonDetails: N/A
SourcePackage: software-properties
Title: software-properties-gtk crashed with AttributeError in __init__(): 'ElementTree' object has no attribute 'getiterator'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lxd plugdev sudo

Revision history for this message
C Schilder (cschilder) wrote :
tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
elguavas (elguavas.) wrote :

as pointed out in bug #1923553 , this bug affects all the various software-properties gui's (including software-properties-qt, software-properties-kde), not just software-properties-gtk.

it is also mentioned in the other bug report that the issue seems to be that the underlying python code being called is using the long deprecated and now removed "getiterator" method in ElementTree to generate the list of "other" download sources.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.99.10

---------------
software-properties (0.99.10) hirsute; urgency=medium

  * softwareproperties/CountryInformation.py:
    - Remove use of getiterator which is deprecated in python3.9
      (lp: #1909918)

  [ Robert Ancell ]
  * Updated translations template

 -- Sebastien Bacher <email address hidden> Fri, 16 Apr 2021 12:05:30 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers