Include a control to display or not the livepatch indicator

Bug #1835910 reported by Sebastien Bacher on 2019-07-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Wishlist
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
The livepatch UI design includes a control in software-properties which let you enable the indicator or not, that UI element is currently missing from bionic

* Test case
- start software-properties
- go the livepatch tab and enable livepatch by adding an account
-> the UI should include a toggle that let you activate/disactive the indicator
- click on the control button
-> the indicator status should reflect the control one

* Regression potential
The change is adding a new widget, it shouldn't impact on existing code but check that the page layout is still correct. The change also include translatable strings, they are being handled the same way as the other livepatch strings added in the previous upload (shared translations between serie included in langpack updates)

summary: - Include control to display or not the indicator
+ Include a control to display or not the livepatch indicator
Sebastien Bacher (seb128) wrote :

The issue was fixed in Eoan with https://launchpad.net/ubuntu/+source/software-properties/0.98.1

It doesn't make sense to SRU to Disco since livepatch is nor available there

Changed in software-properties (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Released

Hello Sebastien, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in software-properties (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Using 0.96.24.32.11 (which includes the changes from here) the control is available and the indicator correctly responds to the status changes, marked as verified

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.32.11

---------------
software-properties (0.96.24.32.11) bionic; urgency=medium

  * cloudarchive: Update outdated WEB_LINK that is presented when
    cloud archive is enabled (LP: #1836258).

 -- Corey Bryant <email address hidden> Fri, 12 Jul 2019 10:10:04 -0400

Changed in software-properties (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers