Livepatch is not available for this system Ubuntu Disco 19.04

Bug #1817352 reported by Edson José dos Santos on 2019-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Andrea Azzarone

Bug Description

Hi guys

There is an option for livepacth, but there is information that is not yet available for Ubuntu Disk 19.04. Will the livepatch be available for Ubuntu Disk 19.04?

"Livepacth is not available for this system"

See attached

Thank you

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: software-properties-gtk 0.97.6
ProcVersionSignature: Ubuntu 4.19.0-13.14-generic 4.19.20
Uname: Linux 4.19.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Feb 22 14:08:04 2019
ExecutablePath: /usr/bin/software-properties-gtk
InstallationDate: Installed on 2019-02-11 (10 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190203)
InterpreterPath: /usr/bin/python3.7
PackageArchitecture: all
Python3Details: /usr/bin/python3.7, Python 3.7.2+, python3-minimal, 3.7.2-1
PythonDetails: /usr/bin/python2.7, Python 2.7.16rc1, python-minimal, 2.7.15-4
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Sebastien Bacher (seb128) wrote :

livepatch is only available for LTS series, maybe the UI coult communicate that better though?

Changed in software-properties (Ubuntu):
importance: Undecided → Low
summary: - Livepacth is not available for this system Ubuntu Disco 19.04
+ Livepatch is not available for this system Ubuntu Disco 19.04
Andrea Azzarone (azzar1) on 2019-02-25
Changed in software-properties (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
importance: Low → Medium
status: New → In Progress
Andrea Azzarone (azzar1) wrote :

I'm attaching a screenshot of how it was supposed to be. There is a small bug in software-properties-gtk that is preventing the error to appear. I've already proposed a fix for this. Thanks for the report.

Changed in software-properties (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.97.7

---------------
software-properties (0.97.7) disco; urgency=medium

  [ Andrea Azzarone ]
  * LivepatchPage: Make sure the scrolled window of the error message view
    is always visible (lp: #1817352)

 -- Sebastien Bacher <email address hidden> Mon, 25 Feb 2019 15:47:00 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released

Hi guys

I just upgraded to an informed version and the problem still continues.

See attachment

*************
Hi Pessoal

Acabei de atualizar para versão informada e o problema ainda continua.

Vide anexo

Matthew Paul Thomas (mpt) wrote :

Edson, apart from the theme and locale, that looks the same as Andrea’s screenshot of the intended behavior.

Andrea Azzarone (azzar1) wrote :

> Edson, apart from the theme and locale, that looks the same as Andrea’s screenshot of the intended behavior.

All those strings are translatable. Maybe "Livepatch is not available for this release" is not clear enough?

Hi Matheus and Andrea Azzarone

A simple efficiency test of live pacth functionality for Ubuntu Disc version 19.04 would not be feasible and sufficient? Why create live patch functionality on something that is not yet available?

I'm sorry for the inconvenience.

Thank you

************************
Hi Matheus e Andrea Azzarone

Um simples teste de eficiência da funcionalidade do live pacth para versão do Ubuntu Disco 19.04 não seria viável e suficiente? Para que criar funcionalidade de live patch em algo que ainda não está disponível?

Me desculpe pelo incomodo

Obrigado

Matthew Paul Thomas (mpt) wrote :

Oi Edson

I don’t know what you mean by “efficiency test”. But to answer your question, these are the use cases we were designing for:

- Someone was using Livepatch in 18.04 LTS, then they upgraded to 19.04, and they skipped past (or forgot) the warning that Livepatch wouldn’t be available after they upgraded, and now they are wondering what’s going on.

- Someone is already using 19.04 when someone tells them about Livepatch, and they don’t know that it’s LTS-only, so they go searching for it in the GUI.

For these cases, the previous behavior — simply hiding the tab altogether — was not helpful. The drawback is that for as long as you keep using non-LTS releases, there will be one tab of stuff that you can’t use. But since that is just one tab in a settings window, I think it’s worthwhile.

Ruud Bos (ruudbos1983) wrote :

Quite annoying that LivePatch does not work with Disco Dingo 19.04.
At work I'm used to work with CentOS, which has reboot-less updates (including kernel) for ages - probably somewhere around the time when kernel 4.0 was released.

Some of the server VM's used to run a server-version of Ubuntu, but even those machines were nagging for required reboots after certain updates. It's like using Microsoft Windows :-/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers