/usr/bin/software-properties-gtk:AttributeError:on_driver_selection_changed

Bug #1807373 reported by errors.ubuntu.com bug bridge on 2018-12-07
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Brian Murray
Xenial
High
Brian Murray
Bionic
High
Brian Murray
Cosmic
High
Brian Murray

Bug Description

[Impact]
software-properties-gtk is crashing regularly for users of Ubuntu stable releases.

[Test Case]
We aren't sure what exactly is causing the crash but we don't need to be given that there is a bucket in the Error Tracker with a large number of crashes. The fix for this bug can be verified by looking at the bucket in the description and confirming that the crash does not occur with the new version of the package.

[Regression Potential]We are just adding in a except check for an AttributeError so there is little chance of a regression, just make sure the change isn't typo'ed.

[Original Description]
The Ubuntu Error Tracker has been receiving reports about a problem regarding software-properties. This problem was most recently seen with package version 1.92.36bodhi1, the problem page at https://errors.ubuntu.com/problem/b13c9466e8741d31ba6c9934365589f383a60650 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
tags: added: rls-dd-incoming
Changed in software-properties (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.29

---------------
software-properties (0.96.29) disco; urgency=medium

  * SoftwarePropertiesGtk.py: when checking a package's depends for DKMS also
    pass on an AttributeError (LP: #1807373)

 -- Brian Murray <email address hidden> Tue, 11 Dec 2018 14:35:40 -0800

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Changed in software-properties (Ubuntu Bionic):
status: New → Triaged
Changed in software-properties (Ubuntu Cosmic):
status: New → Triaged
Changed in software-properties (Ubuntu Bionic):
importance: Undecided → High
Changed in software-properties (Ubuntu Cosmic):
importance: Undecided → High
Changed in software-properties (Ubuntu Bionic):
assignee: nobody → Brian Murray (brian-murray)
Changed in software-properties (Ubuntu Cosmic):
assignee: nobody → Brian Murray (brian-murray)
Changed in software-properties (Ubuntu Bionic):
status: Triaged → In Progress
Changed in software-properties (Ubuntu Cosmic):
status: Triaged → In Progress
description: updated
Changed in software-properties (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)

Hello errors.ubuntu.com, or anyone else affected,

Accepted software-properties into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.27.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in software-properties (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in software-properties (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in software-properties (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted software-properties into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.20.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Brian Murray (brian-murray) wrote :

The new package version numbers do not appear in the bucket at https://errors.ubuntu.com/problem/b13c9466e8741d31ba6c9934365589f383a60650, additionally there are no other crashes re software-properties which are the result of an AttributeError in on_driver_selection changed so there isn't a new crash (because the line numbers changed) about this issue so I'm setting this to v-done.

tags: added: verification-done verification-done-bionic verification-done-cosmic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.20.8

---------------
software-properties (0.96.20.8) xenial; urgency=medium

  * SoftwarePropertiesGtk.py: when checking a package's depends for DKMS also
    pass on an AttributeError (LP: #1807373)

 -- Brian Murray <email address hidden> Mon, 17 Dec 2018 11:21:26 -0800

Changed in software-properties (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-properties has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.32.7

---------------
software-properties (0.96.24.32.7) bionic; urgency=medium

  * SoftwarePropertiesGtk.py: when checking a package's depends for DKMS also
    pass on an AttributeError (LP: #1807373)

 -- Brian Murray <email address hidden> Fri, 14 Dec 2018 11:13:07 -0800

Changed in software-properties (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.27.1

---------------
software-properties (0.96.27.1) cosmic; urgency=medium

  * SoftwarePropertiesGtk.py: when checking a package's depends for DKMS also
    pass on an AttributeError (LP: #1807373)

 -- Brian Murray <email address hidden> Fri, 14 Dec 2018 11:07:55 -0800

Changed in software-properties (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers