Unable to add software sources via the software-properties-qt

Bug #1801439 reported by Clint Steed on 2018-11-03
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Hans P. Möller

Bug Description

Test
1. Start Software-properties. E.g. sudo software-properties-qt
2. Navigate to Other Software (Tab), Add -> Add, to add a PPA
3. Insert the PPA string. E.g. "deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic main " (or even the example repo given in the dialog, which is not a PPA)
4. Click Okay.

The software sources list does not contain the new field. Executing in terminal results in the following error message.

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/softwareproperties/qt/SoftwarePropertiesQt.py", line 627, in on_add_clicked
    self.add_source_from_line(line)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 752, in add_source_from_line
    enable_source_code=enable_source_code)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 769, in add_source_from_shortcut
    worker = self.check_and_add_key_for_whitelisted_shortcut(shortcut)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 709, in check_and_add_key_for_whitelisted_shortcut
    self.options.keyserver)})
AttributeError: type object 'OptionParsed' has no attribute 'keyserver'

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: software-properties-qt 0.96.27
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: LXQt
Date: Sat Nov 3 09:59:52 2018
InstallationDate: Installed on 2018-10-19 (14 days ago)
InstallationMedia: Lubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.2)
PackageArchitecture: all
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Clint Steed (steedalion) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

I followed TEST instructions in description

I got exactly the same output

guiverc@dx6120lu:~$ sudo software-properties-qt
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-pack ...
[redacted ]
 ... has no attribute 'keyserver'

(I saved my output & copy/pasted output from description then `diff -Zb` them & only difference was prompt & XDG_RUNTIME_DIR lines..)

guiverc@dx6120lu:~$ apt-cache policy software-properties-qt
software-properties-qt:
  Installed: 0.96.27
  Candidate: 0.96.27
  Version table:
 *** 0.96.27 500
        500 http://ftp.iinet.net.au/pub/ubuntu cosmic/universe i386 Packages
        100 /var/lib/dpkg/status

// note: my arch is x86 i686

Also fails for the example "deb http://archive.ubuntu.com/ubuntu cosmic main"

Changed in software-properties (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - Unable to add PPA's via the software-properties
+ Unable to add software sources via the software-properties
description: updated
tags: added: rls-dd-incoming
Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

This is specific to software-properties-qt as I was unable to recreate the crash using software-properties-gtk on Ubuntu 18.10.

summary: - Unable to add software sources via the software-properties
+ Unable to add software sources via the software-properties-qt
Clint Steed (steedalion) wrote :

Hi All, I cannot specify software-properties-QT in package. Also the bug title specifically says software-properties-qt.

Simon Quigley (tsimonq2) wrote :

I'll take this one.

Changed in software-properties (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
tags: added: rls-dd-notfixing
removed: rls-dd-incoming
Simon Quigley (tsimonq2) on 2019-03-06
Changed in software-properties (Ubuntu):
assignee: Simon Quigley (tsimonq2) → Hans P Möller (hmollercl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.97.8

---------------
software-properties (0.97.8) disco; urgency=medium

  * Change debconf frontend to kde for software-properties-qt.
  * Change Qt Desktop Entry to be shown in LXQt.
  * Add Drivers Qt Desktop Entry to be shown in LXQt.
  * Fix adding of PPAs (LP: #1801439).
  * Fixed typos in Qt Additional Driver tab.

 -- <email address hidden> (Hans P. Moller) Thu, 21 Feb 2019 22:49:39 -0300

Changed in software-properties (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers