Notification of Live patch sign-in is inconsistent depending on how Software & Updates is started

Bug #1769316 reported by Paul White on 2018-05-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Low
Unassigned

Bug Description

This issue has I think been partly covered in other bug reports that are currently marked incomplete but none describe my exact issue with Livepatch signing in..

I'm creating this report in the hope that it does provide enough information with regards to what I am seeing here and have been doing so since before the release of Ubuntu 18.04.

Last night I enabled Livepatch by signing into the appropriate tab of Software & Updates. As a result of briefly discussing this elsewhere I decided to check whether I was still logged in or not.

1) I started synaptic and pulled up "Software & Updates" from the Settings menu. The Updates tab shows the Livepatch box as being checked but a message of "To use Livepatch you need to sign in" and a Sign-in button is displayed. If I attempt to sign in I see a "Choose an account" dialog. Clicking on "Sign in.." displays an empty panel with "Devices" in the top left corner. This is obviously the Settings application with no text being displayed.

2) I then started "Software & Updates" as a stand alone application. The Updates tab shows that I am signed in, my email address is shown along with a "Sign out" button and the message "Use Canonical Livepatch to increase security between restarts is displayed immediately above.

Restarting "Software & Updates" alternately through synaptic and as a stand alone application shows either an unsuccessful login or a successful log-in as described in points 1) and 2).

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: software-properties-gtk 0.96.24.32.1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat May 5 08:38:38 2018
InstallationDate: Installed on 2017-11-07 (178 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
PackageArchitecture: all
SourcePackage: software-properties
UpgradeStatus: Upgraded to bionic on 2018-02-21 (72 days ago)

Paul White (paulw2u) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) wrote :

The problem is that synaptic launches software-properties-gtk has root. Marking as low considering that synaptic is not officially supported.

Changed in software-properties (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers