LivePatch in Software & Updates shows that LP is not enabled when the U1 account has expired in g-o-a

Bug #1768797 reported by Will Cooke on 2018-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Andrea Azzarone
Bionic
Undecided
Unassigned

Bug Description

* Impact
When the U1 account credential expire it's not possible to disable livepatch

* Test case
- install/enable livepatch (from the first login wizard or software-properties)
- invalidate your U1 credentials:
  * open "Password and Keys"
  * Search for an entry containing "ubuntusso"
  * Right click and open "Properties"
  * Show the password entry
  * Modify the 'macaroon' field (e.g. add a 1 at the beginning of the string so you can easily remote it later)
- open software-properties

-> the livepatch status should be marked as enable but the control active so it's possible to disable it

* Regression potential

Check that the software-properties checkbox reflect the correct status when the account are valid and invalid

----------------

I enabled LivePatch via gnome-initial-setup and added my U1 account to g-o-a.

My U1 account gets marked as expired quite often. When it's expired the LP entry in Software & Updates is not ticked to show that LP is running. When my u1 account is re-authenticated then everything shows correctly.

This could make it seem that LivePatch does not run if your account expires, which is not the case.

Related branches

Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → High
assignee: nobody → Andrea Azzarone (azzar1)
Will Cooke (willcooke) on 2018-05-03
Changed in gnome-online-accounts (Ubuntu):
importance: High → Medium
Andrea Azzarone (azzar1) wrote :

This is what I get when the account is expired. The check-button is not sensible but is ticked. Are you getting something different?

It would also be nice to understand why the accounts tend to expire but it's a different bug that need to be discussed somewhere elese.

Changed in gnome-online-accounts (Ubuntu):
status: New → Incomplete
Will Cooke (willcooke) wrote :

Ah yeah, you're right. It is still checked, but is greyed out.

However, I think that is still misleading as, to me at least, it implies that LivePatch isn't working because I'm not signed in.

Am I right in thinking that you can still disabled LP if the u1 account has expired? If so I think that if LP is active and can be disabled in this state, then it should be possible to disable it without having to refresh the u1 creds.

But, we should get input from design.

Andrea Azzarone (azzar1) wrote :

mtp replied by email:

That is a strange situation. But since there’s no reason to stop you
from turning Livepatch off, the checkbox should still be enabled. The
only thing we can’t do, that we normally would, is tell you what account
you’re signed in as. Instead we can just reassure you that “Livepatch is
active.”

Changed in gnome-online-accounts (Ubuntu):
status: Incomplete → In Progress
Sebastien Bacher (seb128) wrote :

Uploaded to cosmic, do we think that's worth SRUing to bionic?

affects: gnome-online-accounts (Ubuntu) → software-properties (Ubuntu)
Andrea Azzarone (azzar1) wrote :

Yeah this should be SRUed to bionic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.34

---------------
software-properties (0.96.24.34) cosmic; urgency=medium

  [ Andrea Azzarone ]
  * Allow the user to disable livepatch if the gnome-online-account expired.
    (lp: #1768797)

 -- Sebastien Bacher <email address hidden> Wed, 04 Jul 2018 15:38:17 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2018-07-12
tags: added: rls-bb-incoming
description: updated
Andrea Azzarone (azzar1) on 2018-07-12
description: updated

Hello Will, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

0.96.24.32.4 works as described, marking as verified

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.32.4

---------------
software-properties (0.96.24.32.4) bionic; urgency=medium

  [ Andrea Azzarone ]
  * Allow the user to disable livepatch if the gnome-online-account expired.
    (lp: #1768797)

 -- Sebastien Bacher <email address hidden> Wed, 04 Jul 2018 15:38:17 +0200

Changed in software-properties (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-properties has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers