gnome-session-bin installed on Ubuntu MATE

Bug #1762807 reported by Martin Wimpress on 2018-04-10
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu MATE seeds software-properties-gtk which causes gnome-session-bin to be pulled into the Ubuntu MATE image. This issue arises because debian/control doesn't Recommends: mate-session-manager for software-properties-gtk.

To resolve this issue debian/control for software-properties-gtk should be updated to:

Recommends: gnome-session-bin | xfce4-session | lubuntu-default-settings | lxqt-session | mate-session-manager, gnome-keyring

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1762807

tags: added: iso-testing
Simon Quigley (tsimonq2) on 2018-04-10
Changed in software-properties (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.28

---------------
software-properties (0.96.24.28) bionic; urgency=medium

  [ Martin Wimpress ]
  * Allow mate-session-manager to fulfill the gnome-session-bin Recommends
    (LP: #1762807)

  [ Jeremy Bicha ]
  * Add Appstream metadata with compulsory_for_desktop fields to prevent
    the accidental uninstallation of ubuntu-desktop in GNOME Software.
    ubuntu-desktop depends on software-properties-gtk.
  * Build-Depend on dh-python

 -- Jeremy Bicha <email address hidden> Tue, 10 Apr 2018 17:12:59 -0400

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
Vlad Orlov (monsta) wrote :

Thanks, today's ISO doesn't contain gnome-session-bin anymore. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers