Running add-apt-repository inside docker bionic container gives No such file or directory: 'S.gpg-agent.browser'

Bug #1755192 reported by Gijs Molenaar on 2018-03-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

This used to work for Ubuntu 14.04 and 16.04.

```
Step 5/7 : RUN add-apt-repository -y ppa:kernsuite/kern-dev
 ---> Running in 4d6412c3d237
gpg: keybox '/tmp/tmpol6z8f79/pubring.gpg' created
gpg: /tmp/tmpol6z8f79/trustdb.gpg: trustdb created
gpg: key 813B0DC8B7D042E7: public key "Launchpad PPA for KERN suite" imported
gpg: Total number processed: 1
gpg: imported: 1
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
[Errno 2] No such file or directory: 'S.gpg-agent.browser'
```

Dockerfile:

```
FROM ubuntu:18.04
MAINTAINER <email address hidden>
RUN apt-get update
RUN apt-get install -y software-properties-common
RUN add-apt-repository -y ppa:kernsuite/kern-dev
```

Related branches

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
tags: added: bionic rls-bb-incoming
Steve Langasek (vorlon) on 2018-03-22
Changed in software-properties (Ubuntu Bionic):
importance: Undecided → High
tags: removed: rls-bb-incoming
tags: added: id-5ab3cac0312039470971785a
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.25

---------------
software-properties (0.96.24.25) bionic; urgency=medium

  * ppa.py:
   - rework key retrieval, instead of using hkp & gnupg/dirmngr, use https
     & python's built in urllib.
   - thus, add-apt-key for PPAs observes https_proxy for key retrieval
   - simplify gnupg operations, depend on gpg package only, and use
     import/public key operations only.
   - fix unicode process output bugs, when operating in a non-UTF-8
     locale, thus enabling to import keys for my ppas in C locale.
   - avoid creating trustdb, or requiring any gpg-agent systemd socket to
     be activated
   - update tests to execute key addition fully with less things stubbed
     out with mock
   - stop using apt-key for installing keys
   - dirmngr is a heavy dependency and not used, and it is hard to pass
     proxy information to it when invoking gpg from a non-standard homedir
   - deprecate --keyserver option, making HTTPS access to
     keyserver.ubuntu.com required
   - LP: #1755192, LP: #1713962, LP: #1699086, LP: #1510220, LP: #1433761,
     LP: #1395321, LP: #1312267

 -- Dimitri John Ledkov <email address hidden> Mon, 02 Apr 2018 10:19:34 +0100

Changed in software-properties (Ubuntu Bionic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers