Software & Updates application does not permit changes on the "Other Software" tab

Bug #1727908 reported by PJSingh5000
150
This bug affects 27 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Fix Released
High
Sebastien Bacher
Bionic
Fix Released
High
Sebastien Bacher

Bug Description

* Impact
Changes on the 'Other Software tab' sometime fail to ask for credential and fail to apply as a consequence

* Test Case
- start software-properties-gtk
- got to the 'Other Software Tab'
- try to change the value of a checkbox

The change should prompt for a password and be active

* Regression potential
the change is a small sleep workaround to avoid trying to get the focus while GTK still has it, outside of a tiny delay in the active it should have no consequence

---------------

On the "Other Software" tab, I am unable to select "Canonical Partners".
Similarly, the other checkboxes on the "Other Software" can not be clicked.
Clicking on a checkbox has no effect, and a dialog requesting the admin password is not presented.

However, activating or deactivating checkboxes on other tabs causes an authorization dialog to be presented to the user.

I experience this bug in an an Xorg session.

sources.list and sources.list.d have the following permissions:
-rw-r--r-- 1 root root 2897 Oct 26 22:35 sources.list
drwxr-xr-x 2 root root 4096 Oct 26 21:29 sources.list.d

All files in sources.list.d have the following permissions as this example:
-rw-r--r-- 1 root root 189 Oct 25 21:50 google-chrome.list

$ lsb_release -rd
Description: Ubuntu 17.10
Release: 17.10

$ apt-cache policy software-properties-gtk
software-properties-gtk:
  Installed: 0.96.24.17
  Candidate: 0.96.24.17
  Version table:
 *** 0.96.24.17 500
        500 http://us.archive.ubuntu.com/ubuntu artful/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu artful/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: software-properties-gtk 0.96.24.17
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: wl nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Oct 26 22:45:09 2017
InstallationDate: Installed on 2017-10-26 (1 days ago)
InstallationMedia: Ubuntu 17.10.0 2017.10.25 amd64 "Custom Artful Aardvark"
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :
Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Note, when I run software-properties-gtk from the command line, here is the output I receive whenever I click on a checkbox on the "Other Software" tab.

$ software-properties-gtk
ERROR:root:Authentication canceled, changes have not been saved

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Revision history for this message
Norbert (nrbrtx) wrote :

Got the same bug in 17.10 on Ubuntu on Xorg.

Steps to reproduce:
1. Install Ubuntu 17.10
2. Login to Ubuntu on Xorg session
3. Launch software-properties-gtk from terminal
4. Open "Other Software" tab, click on checkbox near "Canonical partners"
5. Get "ERROR:root:Authentication canceled, changes have not been saved" in terminal

Seems to be a side-effect of PolicyKit and root applications modern behavior (bug 1713313).

Revision history for this message
Dan (dannyhajj) wrote :

This may be a duplicate of bug 1660100.

However, I'm also suffering from the same issue. But I'd like to add that, after trying to edit any of the entries and clicking "OK" in the dialog that shows up, the password prompts shows up. After we input the password, the ability to check/uncheck entries in the "Other Software" tab becomes possible.

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

After I click on the "Canonical Partners" on the "Other Software" tab, I do ~not~ see an OK button. Also, I am not prompted to enter a password.

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

After I click on the "Canonical Partners" on the "Other Software" tab, I do ~not~ see an OK button. Also, I am not prompted to enter a password.

Paul White (paulw2u)
tags: added: bionic
Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

I have the same problem on at least 6 computers with 18.04.1 now.

Revision history for this message
jimlovell777 (jimlovell777) wrote :

Temporary work-around: Rapidly clicking the checkbox will trigger the prompt for your password and make the desired change.

Revision history for this message
Ganesh Bhat (gakubhat) wrote :

Work-around : User arrow keys and press space to select

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I can't confirm that problem neither on 18.04 nor 18.10 though, it might be specific to some configuration/theme/session. Do you use the standard ubuntu session?

Changed in software-properties (Ubuntu):
importance: Undecided → High
Revision history for this message
Paul White (paulw2u) wrote :

Sebastien, at present I can't confirm this on Xubuntu 18.04 but I still see a problem with Ubuntu 18.04 for which I have vanilla-gnome-desktop installed so using the Adwaita theme·

If I try to select or deselect anything on the "Other Software" tab I see the panel dim slightly as if the prompt for the admin password was going to appear but it doesn't. Just this tab is affected.

But *sometimes* if I first select an item on another tab, cancel the password prompt and return to the "Other Software" tab then the password prompt does appear when selecting or deselecting an item.

Unfortunately, the above is not reproducible every time and while testing before posting here (by repeatedly switching tabs and trying to select or deselect items) the application crashed and invited me to send a crash report.

I see this problem when starting Software & Updates as a stand alone application and also through GNOME Software but not through synaptic as my password has already been entered.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Using GTK_THEME=Adwaita software-properties-gtk works fine as well...

Revision history for this message
Harald H. (haarektrans) wrote :

Can confirm that this is reproducible with the standard Ubuntu session in 18.04.01 and 18.10, tested both with the vanilla install with no updates and also fully updated.

However, notice a few things:
- If you repeatedly click the checkbox it will sometimes trigger the authentication window
- The issue is *only* reproducible when the user do not have the permission to apply the changes (ie. before triggering the authentication window).
It will also not be reproducible in a live session.

Revision history for this message
Doug McMahon (mc3man) wrote :

This definitely occurs in both 18.04 & 19.04 but only in a ubuntu (gnome) session
Is not an issue in wayland or unity(7) sessions

tags: added: disco gnome-session
Revision history for this message
Sebastien Bacher (seb128) wrote :

Well, I can't trigger the issue on fresh 18.04 or 18.10 Ubuntu install with the default session, could be a timing issue and specific to some configs...

Revision history for this message
Doug McMahon (mc3man) wrote :

This is what I get (fresh, updated 19.04

Dec 20 09:17:35 doug-Lenovo-IdeaPad-Y510P gnome-shell[4457]: polkitAuthenticationAgent: Failed to show modal dialog. Dismissing authentication request for action-id com.ubuntu.softwareproperties.applychanges cookie 2-31d1ccd7a01566b1680571cf9fb9578b-34-00b0dcf0e126b16d033d5395b622edd2
Dec 20 09:17:35 doug-Lenovo-IdeaPad-Y510P polkitd(authority=local)[1130]: Operator of unix-session:c4 FAILED to authenticate to gain authorization for action com.ubuntu.softwareproperties.applychanges for system-bus-name::1.592 [/usr/bin/python3 /usr/bin/software-properties-gtk] (owned by unix-user:doug)
Dec 20 09:17:35 doug-Lenovo-IdeaPad-Y510P software-properties-gtk.desktop[4457]: ERROR:root:Authentication canceled, changes have not been saved

Revision history for this message
Sebastien Bacher (seb128) wrote :

the gnome-shell error is a bit weird, maybe there is an issue on this component

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Bjoern H. (bhsand) wrote :

I have this issue both in 18.10 and 19.04. Using arrows and space does not work, the only workaround I've found is "sudo software-properties-gtk". Would be happy to provide any details that could be useful.

Revision history for this message
Chris Rainey (ckrzen) wrote : Re: [Bug 1727908] Re: Software & Updates application does not permit changes on the "Other Software" tab

I find that primary(left-clicking) up to 15 or 20+ times _eventually_
spawns the pkexec-gui box.

On Wed, Mar 20, 2019 at 9:26 AM Bjoern H. <email address hidden>
wrote:

> I have this issue both in 18.10 and 19.04. Using arrows and space does
> not work, the only workaround I've found is "sudo software-properties-
> gtk". Would be happy to provide any details that could be useful.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1727908
>
> Title:
> Software & Updates application does not permit changes on the "Other
> Software" tab
>
> Status in gnome-shell package in Ubuntu:
> Confirmed
> Status in software-properties package in Ubuntu:
> Confirmed
>
> Bug description:
>
> On the "Other Software" tab, I am unable to select "Canonical Partners".
> Similarly, the other checkboxes on the "Other Software" can not be
> clicked.
> Clicking on a checkbox has no effect, and a dialog requesting the admin
> password is not presented.
>
> However, activating or deactivating checkboxes on other tabs causes an
> authorization dialog to be presented to the user.
>
> I experience this bug in an an Xorg session.
>
> sources.list and sources.list.d have the following permissions:
> -rw-r--r-- 1 root root 2897 Oct 26 22:35 sources.list
> drwxr-xr-x 2 root root 4096 Oct 26 21:29 sources.list.d
>
> All files in sources.list.d have the following permissions as this
> example:
> -rw-r--r-- 1 root root 189 Oct 25 21:50 google-chrome.list
>
> $ lsb_release -rd
> Description: Ubuntu 17.10
> Release: 17.10
>
> $ apt-cache policy software-properties-gtk
> software-properties-gtk:
> Installed: 0.96.24.17
> Candidate: 0.96.24.17
> Version table:
> *** 0.96.24.17 500
> 500 http://us.archive.ubuntu.com/ubuntu artful/main amd64
> Packages
> 500 http://us.archive.ubuntu.com/ubuntu artful/main i386
> Packages
> 100 /var/lib/dpkg/status
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: software-properties-gtk 0.96.24.17
> ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
> Uname: Linux 4.13.0-16-generic x86_64
> NonfreeKernelModules: wl nvidia_uvm nvidia_drm nvidia_modeset nvidia
> ApportVersion: 2.20.7-0ubuntu3.1
> Architecture: amd64
> CurrentDesktop: GNOME
> Date: Thu Oct 26 22:45:09 2017
> InstallationDate: Installed on 2017-10-26 (1 days ago)
> InstallationMedia: Ubuntu 17.10.0 2017.10.25 amd64 "Custom Artful
> Aardvark"
> PackageArchitecture: all
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-properties
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1727908/+subscriptions
>

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Interesting...

I tried that, and I noticed that 4 rapid clicks (actually taps on my touchpad) consistently brings up the pkexec password box. Less than 3 doesn't work, and more than 4 are not necessary.

Once you've been authenticated, you are able to make changes on the Other Software tab, as you would expect.

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Oops, I meant to say, "Less than *4* doesn't work, and more than 4 are not necessary."

Norbert (nrbrtx)
tags: added: eoan
removed: amd64
Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Still present in Ubuntu 19.04, fresh install.

(Although, now, clicking twice seems to bring up the authentication dialog, and you don't have to click very rapidly).

Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Ubuntu version 19.04
GTK3 version 3.24.8-1ubuntu1
Gnome Shell Version 3.32.0

Revision history for this message
SunBear (sunbear-c22) wrote :

I encountered this same issue in a freshly installed Ubuntu 18.04 system.

$ uname -a
Linux Machine 5.0.0-25-generic #26~18.04.1-Ubuntu SMP Thu Aug 1 13:51:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -rd
Description: Ubuntu 18.04.3 LTS
Release: 18.04

$ gnome-shell --version
GNOME Shell 3.28.4

To discover the error, I ran this app via command line:
$ /usr/bin/python3 /usr/bin/software-properties-gtk
ERROR:root:Authentication canceled, changes have not been saved
ERROR:root:Authentication canceled, changes have not been saved
ERROR:root:Authentication canceled, changes have not been saved
ERROR:root:Authentication canceled, changes have not been saved
ERROR:root:Authentication canceled, changes have not been saved
ERROR:root:Authentication canceled, changes have not been saved

The above errors appear every time the mouse arrow left-clicks on the checkbox.

I circumvent this issue by:
1. left-click on Canonical Partners to select it.
2. left click on the edit button.
3. after the Edit Source GUI appeared, I left-clicked on the "OK" button.
4. finally when I left-click on the checkbox of Canonical Partners, the checkbox becomes selected.

Revision history for this message
SunBear (sunbear-c22) wrote :

I discovered that the Software & Updates application "Authentication" tab's "Remove" button does not work properly too. After pressing the "Remove" button, pkexec was called. After submitting the password for administration level, nothing happens, i.e. Trusted software keys that was selected for deletion do not get removed. Not error was shown in terminal.

$ dpkg -l | grep software-properties
ii python3-software-properties 0.96.24.32.11 all manage the repositories that you install software from
ii software-properties-common 0.96.24.32.11 all manage the repositories that you install software from (common)
ii software-properties-gtk 0.96.24.32.11 all manage the repositories that you install software from (gtk)

I had filed a bug report (see https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1840624). Should it fall under this bug report too and this bug report's title be amended to include the "Authentication" Tab?

tags: added: rls-bb-incoming
Revision history for this message
Will Cooke (willcooke) wrote :

Assigning to Seb since he's looked at it. Please assign to me if I can help test / produce.

Changed in software-properties (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
tags: removed: rls-bb-incoming
Changed in software-properties (Ubuntu Bionic):
assignee: nobody → Sebastien Bacher (seb128)
Will Cooke (willcooke)
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Sebastien Bacher (seb128)
Changed in gnome-shell (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu Bionic):
status: New → Confirmed
Changed in software-properties (Ubuntu Bionic):
status: New → Confirmed
Revision history for this message
Abdul Rauf (armujahid) wrote :

I am also facing this issue in Ubuntu 19.10 Eoan Ermine

Revision history for this message
fcole90 (fcole90) wrote :

Just tested on focal. I didn't have the repo, so I added it:
```
deb http://archive.canonical.com/ubuntu focal partner
```
It correctly asked me the password and after that it was added. I deselected it to verify this bug.
Then I closed the software-properties-gtk window.

To then verify the bug, I opened again software-properties-gtk (from Dash), moved to Other Software and clicked on the Canonical Partners repo. On click nothing appeared (we would be expecting a password prompt) but the window got unselected, like if I had moved to some other window.

Revision history for this message
fcole90 (fcole90) wrote :

Video of the bug

Revision history for this message
fcole90 (fcole90) wrote :

What this triggers in the logs:

gnome-shell:
> polkitAuthenticationAgent: Received 2 identities that can be used for authentication. Only considering one.
> pushModal: invocation of begin_modal failed
> polkitAuthenticationAgent: Failed to show modal dialog. Dismissing authentication request for action-id com.ubuntu.softwareproperties.applychanges cookie 7-b2a6e60b05bc38c7fd20137335c2abcb-34-cd8e89ea6620c9969383c39013bf86c1

polkitd:
> Operator of unix-session:2 FAILED to authenticate to gain authorization for action com.ubuntu.softwareproperties.applychanges for system-bus-name::1.26625 [/usr/bin/python3 /usr/bin/software-properties-gtk] (owned by unix-user:fabio)

gnome-shell:
> ERROR:root:Authentication canceled, changes have not been saved

tags: removed: disco
tags: removed: artful
Revision history for this message
Sønke Lorenzen (solorenzen) wrote :

I saw this bug mentioned on https://discourse.ubuntu.com/t/release-bugs-for-week-commencing-monday-24th-february-2020/14540

with the comment "can’t confirm, lew activity, suggest we untarget from rls set"

It would really be a shame if this stays the way it is now, since it is annoying for those that are hit by it, although with an easy workaround, just do anything else requiring authorisation, and then the toggles work too. For example highlighting one source and then selecting edit and then ok without do any changes. Or just repeating the mouse clicks until it works like others wrote.

But those workarounds are not obvious for all new users.

I can reproduce it by trying to toggle the extra sources with my mouse, It seems to work every time with keyboard though, maybe that is the reason not to be able to reproduce?

This is on several different systems, both on physical hardware and in virtualbox, ranging from 18.04 to 20.04 including all those in between.

And this is not just for the Canonical Partners repository, but any repositories I have in a system.

On some system with not much extra or even fresh installs of 19.04 and 19.10 I can not reproduce it every time on the first try, but closing software-properties-gtk down and starting it again seems to increase the chance of a failure by a lot. So please try closing and opening a few times if you can not reproduce the bug.

I am not sure but I think that app indicators like psensor and indicator-cpufreq also increase the chance of failure to display the authorization window.

If I try to toggle an apt source and do not fix it with one of the working functions, or by repeating the mouse clicks, but instead wait for the screenlock to come and then unlock it, I actually get an authorisation window in the upper left corner. It does take my password, but software-properties-gtk does not get notified by it then.

Mint asks for authorising right away on starting their modified software-properties-gtk, so they do not get this problem.

If the bug can not be found and fixed in time for 20.04, could we then get a "unlock" button on the "Other Software" tab?
Once any of the other functions that requires authorization have been used, the toggles on the "Other Software" tab do work every time.
The "Revert" button actually gets active after the authorisation for the toggles fails, and that reliably opens the authorisation window.
So maybe it could start active but with the text "Unlock" and then changing to the text "Revert" after a successful authorisation.
Then there would be an obvious way for users that do not know the workarounds to toggle software sources, and those that do not experience the bug will not see any functionality changes.

Revision history for this message
Bjoern H. (bhsand) wrote :

Agreed, the low activity could be because the bug is confirmed, reproduced and set at high priority. Most users who face the same issue (myself included) won't see any reason to add to the issue when a solution seems to be on its way.

Revision history for this message
Gre0 (gre0) wrote :

As already mentioned...
> Mouse-click/s do not work (no feedback) and produces an error in the terminal.
> Keyboard navigation and 'Enter' works fine (Authentication window appears)

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I see this issue in focal. Nothing happens if I try to enable or disable a source in the "Other Software" tab by clicking a checkbox. I get the same error message as mentioned in comment #2 if I start software-properties-gtk in terminal.

Adding or removing sources works, but not enabling/disabling them.

tags: added: focal
Revision history for this message
Sebastien Bacher (seb128) wrote :

Ok, I'm a machine where I get the issue now

editing /usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py
l853 in def on_isv_source_toggled
to add (before the try)
import time
time.sleep(0.1)

seems enough to workaround the bug

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → Invalid
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Sebastien: I can confirm that your workaround fixes it for me. (Race condition?)

Would be nice if it could be uploaded to focal to start with...

Revision history for this message
Sebastien Bacher (seb128) wrote :

@Gunnar, thanks for testing! The sleep is a workaround, not a proper fix though. I would guess that something in the gtk widgets used is taking a grab which prevents the shell to be able to displays it's dialog so the proper fix would be to try to understand if that's an event or something we need to wait on before doing the call to polkit. If I don't success to find a better fix I will upload the sleep workaround

Changed in software-properties (Ubuntu):
status: Confirmed → In Progress
Changed in software-properties (Ubuntu Bionic):
importance: Undecided → High
Mathew Hodson (mhodson)
no longer affects: gnome-shell (Ubuntu Bionic)
no longer affects: gnome-shell (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.98.9

---------------
software-properties (0.98.9) focal; urgency=medium

  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - Gtk is doing something that takes a lock while processing checkbox
      toggled events, the polkit auth dialog can't be displayed in return,
      we don't have a proper fix and it might require GTK changes,
      meanwhile we want a working interface so workaround with a sleep
      (lp: #1727908)

 -- Sebastien Bacher <email address hidden> Thu, 16 Apr 2020 11:57:50 +0200

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
description: updated
Changed in software-properties (Ubuntu Bionic):
status: Confirmed → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello PJSingh5000, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Verified the test case using software-properties-gtk 0.96.24.32.13 from bionic-proposed.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Paul White (paulw2u) wrote :

I had already applied the temporary fix as per comment #39 but I upgraded to version 0.96.24.32.13 in -proposed anyway. Attempting to check/uncheck any of the options on the 'Other Software' tab displayed a prompt to enter the 'admin' password. So I can also verify the issue will be fixed with this update.

Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for software-properties has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.32.13

---------------
software-properties (0.96.24.32.13) bionic; urgency=medium

  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - Gtk is doing something that takes a lock while processing checkbox
      toggled events, the polkit auth dialog can't be displayed in return,
      we don't have a proper fix and it might require GTK changes,
      meanwhile we want a working interface so workaround with a sleep
      (lp: #1727908)

 -- Sebastien Bacher <email address hidden> Fri, 08 May 2020 16:47:19 +0200

Changed in software-properties (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers