dep8 tests are failing in zesty

Bug #1670399 reported by Scott Moser on 2017-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned

Bug Description

software-properties tests are failing in autopkgtests.
 http://autopkgtest.ubuntu.com/packages/s/software-properties/zesty/amd64

The first failure is just lack of 'gpg1' in the build environment.

then after that, we still get some failures in my environment at least (running in lxc container).

$ sudo xvfb-run -e my.log sh -ec "python3 setup.py test"

http://paste.ubuntu.com/24125361/

Related branches

Scott Moser (smoser) on 2017-03-06
Changed in software-properties (Ubuntu):
status: New → Confirmed
status: Confirmed → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.11

---------------
software-properties (0.96.24.11) zesty; urgency=medium

  [Scott Moser]
  * debian/tests/run-tests: use gpg rather than gpg1, and show errors
    (LP: #1670399)
  * debian/tests/control: add gnupg to list of dependencies.

  [Iain Lane]
  * softwareproperties/shortcuts.py: Make add_key() return True. Since r988,
    the return value of add_key() is now used to raise an exception.
    ShortcutHandler.add_key() always succeeds, so should return True. This
    (LP: #1670399)

 -- Scott Moser <email address hidden> Mon, 06 Mar 2017 12:22:03 -0500

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers