Unable to enable or disable repository in Software & Updates

Bug #1660100 reported by PJSingh5000 on 2017-01-29
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

The Software & Updates dialog (software-properties-gtk) does not allow the user to activate or deactivate repositories.

RECREATE ISSUE:

Launch Software & Updates.
Select Other Sources tab.
Click on a check box next to a repository to enable or disable it.

RESULT:

The window seems to lose focus, but noting happens.

EXPECTED RESULT:

A dialog should appear prompting the user to enter the administrator password.
After the password is successfully entered, the repository check box should be toggled (enabled or disabled).

OTHER DETAILS:

This issue was tested on Ubuntu-Gnome.

$ lsb_release --all
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.10
Release: 16.10
Codename: yakkety

$ uname -a
Linux PS001 4.8.0-34-generic #36-Ubuntu SMP Wed Dec 21 17:24:18 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: software-properties-gtk 0.96.24.7
ProcVersionSignature: Ubuntu 4.8.0-34.36-generic 4.8.11
Uname: Linux 4.8.0-34-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Jan 28 23:14:17 2017
InstallationDate: Installed on 2017-01-24 (4 days ago)
InstallationMedia: Ubuntu-GNOME 16.10.0 2017.01.23 amd64 "Custom Yakkety Yak"
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

PJSingh5000 (pjsingh5000) wrote :
PJSingh5000 (pjsingh5000) wrote :

When software-properties-gtk is run from the terminal, the following error is displayed:

$ software-properties-gtk
ERROR:root:Authentication canceled, changes have not been saved

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Adric Norris (landstander668) wrote :

I'm seeing the exact same problem, on an up-to-date Ubuntu 16.10 amd64 installation. The only oddity to my configuration is that I'm running the 4.9.6-040906-generic mainline kernel, because the stock Ubuntu kernel has stability issues with the ASUS Zenbook UX501VW. Based upon the original submitter's reported kernel, however, I doubt that's significant to this bug.

For what it's worth, other activities which need to display the authentication dialog (such as unlocking a SSH key) don't appear to be encountering any difficulty.

Adric Norris (landstander668) wrote :

Just for fun I tried upgrading software-properties-gtk to version 0.96.24.8 (along with both dependencies) from "http://us.archive.ubuntu.com/ubuntu/pool/main/s/software-properties/". Unfortunately that didn't make any apparent difference.

I also tried downgrading to version 0.96.20.5, which also exhibits the same failure.

Adric Norris (landstander668) wrote :

I've attached a strace of software-properties-gtk, taken with the "strace -fr -o software-properties-gtk.strace software-properties-gtk" command. The only thing which stands out to me is that there are a *lot* of EAGAIN entries for file descriptor 3, which appears to be the local "/tmp/.X11-unix/X0" socket. The file exists, and has what I'd expect to be usable ownership and permissions.

     $ ls -l /tmp/.X11-unix/X0
     srwxrwxrwx 1 adric adric 0 Feb 12 09:24 /tmp/.X11-unix/X0

AS PJSingh5000 indicated, the only message displayed on the terminal was

   ERROR:root:Authentication canceled, changes have not been saved

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers