if linux metapackage is installed software properties will uninstall it

Bug #1506169 reported by Bryan Quigley on 2015-10-14
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Brian Murray
Trusty
High
Brian Murray
Vivid
High
Brian Murray
Wily
High
Brian Murray

Bug Description

Test Case
---------
Reproduction Steps (works on Live CD, check that linux-generic is installed before testing):
1. Open software-properties-gtk, in the drivers tab install nvidia-352 driver. (It is possible to fake the hardware via /usr/share/ubuntu-drivers-common/fake-devices-wrapper software-properties-gtk.)
2. tail /var/log/apt/history.log and note that it also removed the linux-generic package.
3. Run sudo apt-get upgrade and note that it now mentions that that linux-headers/image-generic are auto-removable.

With the version of the package from -proposed the linux-generic package will no longer be removed by software-properties.

ProblemType: BugDistroRelease: Ubuntu 15.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
Date: Wed Oct 14 14:06:29 2015
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash ---
InstallationDate: Installed on 2015-10-13 (1 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151013)
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Bryan Quigley (bryanquigley) wrote :
Bryan Quigley (bryanquigley) wrote :

The reason I reinstalled was because the kernel had been removed from my previous install. Maybe I am doing something wrong?

It looks like it was removed about the time I added the graphics-drivers ppa - https://launchpad.net/~graphics-driver

Bryan Quigley (bryanquigley) wrote :

and by it, I mean the linux-generic package.

Adam Conrad (adconrad) wrote :

Definitely looks like it's being removed in the same pass as adding the nvidia drivers. Would be good to hunt that down. Do you have the apt logs?

Bryan Quigley (bryanquigley) wrote :

from history.log:
Start-Date: 2015-10-13 14:40:22
Commandline: aptdaemon role='role-commit-packages' sender=':1.304'
Install: screen-resolution-extra:amd64 (0.17.1, automatic), lib32gcc1:amd64 (5.2.1-22ubuntu1, automatic), libjansson4:amd64 (2.7-1ubuntu1, automatic), dkms:amd64 (2.2.0.3-2ubuntu6, automatic), nvidia-settings:amd64 (355.11-0ubuntu0~gpu15.10.1, automatic), libcuda1-355:amd64 (355.11-0ubuntu0~gpu15.10.1, automatic), ocl-icd-libopencl1:amd64 (2.2.7-2, automatic), nvidia-355:amd64 (355.11-0ubuntu0~gpu15.10.1), bbswitch-dkms:amd64 (0.7-2ubuntu1, automatic), nvidia-opencl-icd-355:amd64 (355.11-0ubuntu0~gpu15.10.1, automatic), nvidia-prime:amd64 (0.8.1, automatic), libc6-i386:amd64 (2.21-0ubuntu4, automatic), libvdpau1:amd64 (1.1.1-0ubuntu0~gpu15.10.5, automatic), libxnvctrl0:amd64 (355.11-0ubuntu0~gpu15.10.1, automatic)
Remove: linux-generic:amd64 (4.2.0.16.17)
End-Date: 2015-10-13 14:41:54

Bryan Quigley (bryanquigley) wrote :

I can reproduce this on a livecd. It also doesn't depend on the graphics driver ppa, it's reproducible wth nvidia-352 in restricted.

Reproducible with stock nvidia-352 and the ubuntu-drivers gui
Start-Date: 2015-10-14 21:43:21
Commandline: aptdaemon role='role-commit-packages' sender=':1.69'
Install: screen-resolution-extra:amd64 (0.17.1, automatic), lib32gcc1:amd64 (5.2.1-22ubuntu1, automatic), libjansson4:amd64 (2.7-1ubuntu1, automatic), dkms:amd64 (2.2.0.3-2ubuntu6, automatic), nvidia-settings:amd64 (352.21-0ubuntu1, automatic), libcuda1-352:amd64 (352.41-0ubuntu1, automatic), ocl-icd-libopencl1:amd64 (2.2.7-2, automatic), nvidia-352:amd64 (352.41-0ubuntu1), bbswitch-dkms:amd64 (0.7-2ubuntu1, automatic), nvidia-opencl-icd-352:amd64 (352.41-0ubuntu1, automatic), nvidia-prime:amd64 (0.8.1, automatic), libc6-i386:amd64 (2.21-0ubuntu4, automatic), libvdpau1:amd64 (1.1-1ubuntu1, automatic), libxnvctrl0:amd64 (352.21-0ubuntu1, automatic)
Remove: linux-generic:amd64 (4.2.0.16.17)

NOT reproducible with stock nvidia-353 and the ubuntu-drivers autoinstall command
Start-Date: 2015-10-14 21:50:17
Commandline: apt-get install -o DPkg::options::=--force-confnew -y nvidia-352
Install: screen-resolution-extra:amd64 (0.17.1, automatic), lib32gcc1:amd64 (5.2.1-22ubuntu1, automatic), libjansson4:amd64 (2.7-1ubuntu1, automatic), dkms:amd64 (2.2.0.3-2ubuntu6, automatic), nvidia-settings:amd64 (352.21-0ubuntu1, automatic), libcuda1-352:amd64 (352.41-0ubuntu1, automatic), ocl-icd-libopencl1:amd64 (2.2.7-2, automatic), nvidia-352:amd64 (352.41-0ubuntu1), bbswitch-dkms:amd64 (0.7-2ubuntu1, automatic), nvidia-opencl-icd-352:amd64 (352.41-0ubuntu1, automatic), nvidia-prime:amd64 (0.8.1, automatic), libc6-i386:amd64 (2.21-0ubuntu4, automatic), libvdpau1:amd64 (1.1-1ubuntu1, automatic), libxnvctrl0:amd64 (352.21-0ubuntu1, automatic)

Bryan Quigley (bryanquigley) wrote :

I believe I found where the problem lies - with the attached diff the problem goes away (this is NOT a fix). It's specific to the gtk code.

affects: ubiquity (Ubuntu) → software-properties (Ubuntu)
description: updated
description: updated
Brian Murray (brian-murray) wrote :

I was able to recreate this:

Start-Date: 2015-10-23 09:38:35
Commandline: aptdaemon role='role-commit-packages' sender=':1.8011'
Install: libcuda1-352:amd64 (352.41-0ubuntu1, automatic), ocl-icd-libopencl1:amd64 (2.2.7-2, automatic), nvidia-352:amd64 (352.41-0ubuntu1), nvidia-opencl-icd-352:amd64 (352.41-0ubuntu1, automatic)
Remove: libcuda1-340:amd64 (340.93-0ubuntu1), nvidia-331:amd64 (340.93-0ubuntu1), nvidia-340:amd64 (340.93-0ubuntu1), nvidia-libopencl1-340:amd64 (340.93-0ubuntu1), nvidia-opencl-icd-340:amd64 (340.93-0ubuntu1), nvidia-340-uvm:amd64 (340.93-0ubuntu1), linux-generic:amd64 (4.2.0.16.18)
End-Date: 2015-10-23 09:39:56

Brian Murray (brian-murray) wrote :

Switching back to nouveau seemed to fix the issue.

Start-Date: 2015-10-23 09:51:43
Commandline: aptdaemon role='role-commit-packages' sender=':1.8016'
Install: linux-generic:amd64 (4.2.0.16.18)
Remove: nvidia-352:amd64 (352.41-0ubuntu1)
End-Date: 2015-10-23 09:51:58

Brian Murray (brian-murray) wrote :

I think this is because the intent of installing the linux metapackage as described here:

1171 # If the package depends on dkms
1172 # we need to install the correct linux metapackage
1173 # so that users get the latest headers
1174 if 'dkms' in pkg.candidate.record['Depends']:
1175 linux_meta = detect.get_linux(self.apt_cache)
1176 if (linux_meta and
1177 linux_meta not in self.driver_changes):
1178 # Install the linux metapackage
1179 self.driver_changes.append(self.apt_cache[linux_meta])

Is not honored if the package is already installed:

1048 def on_driver_changes_apply(self, button):
1049
1050 installs = []
1051 removals = []
1052
1053 for pkg in self.driver_changes:
1054 if pkg.is_installed:
1055 removals.append(pkg.shortname)
1056 else:
1057 installs.append(pkg.shortname)

Changed in software-properties (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
summary: - fresh install - linux-headers-generic linux-image-generic python-notify
- thermald can be auto removed
+ if linux metapackage is installed software properties will uninstall it
Changed in software-properties (Ubuntu Wily):
importance: Undecided → High
status: New → Triaged
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.15

---------------
software-properties (0.96.15) xenial; urgency=medium

  [ Barry Warsaw ]
  * In ppa.py, shortcut_handler(), if a ShortcutException occurs, print
    the traceback to stderr and return None to allow other shortcut
    handlers to run. (LP: #1510558)

 -- Brian Murray <email address hidden> Tue, 27 Oct 2015 11:25:08 -0700

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Changed in software-properties (Ubuntu Wily):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
description: updated
Changed in software-properties (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → High

Hello Bryan, or anyone else affected,

Accepted software-properties into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.13.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Wily):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in software-properties (Ubuntu Vivid):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in software-properties (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Chris J Arges (arges) wrote :

Hello Bryan, or anyone else affected,

Accepted software-properties into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.92.37.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in software-properties (Ubuntu Vivid):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Bryan, or anyone else affected,

Accepted software-properties into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done-wily verification-needed-trusty verification-needed-vivid
removed: verification-needed
Brian Murray (brian-murray) wrote :

I've verified this fix in Vivid.

bdmurray@clean-vivid-amd64:~$ tail /var/log/apt/history.log
Commandline: apt-get install linux-generic
Install: linux-image-extra-3.19.0-32-generic:amd64 (3.19.0-32.37, automatic), linux-image-3.19.0-32-generic:amd64 (3.19.0-32.37, automatic), linux-headers-3.19.0-32-generic:amd64 (3.19.0-32.37, automatic), linux-headers-3.19.0-32:amd64 (3.19.0-32.37, automatic), linux-generic:amd64 (3.19.0.32.31)
Upgrade: linux-headers-generic:amd64 (3.19.0.31.30, 3.19.0.32.31), linux-image-generic:amd64 (3.19.0.31.30, 3.19.0.32.31)
End-Date: 2015-10-29 09:33:22

Start-Date: 2015-10-29 09:34:47
Commandline: aptdaemon role='role-commit-packages' sender=':1.99'
Install: nvidia-opencl-icd-304-updates:amd64 (304.128-0ubuntu0.1, automatic), libcuda1-304-updates:amd64 (304.128-0ubuntu0.1, automatic), nvidia-304-updates:amd64 (304.128-0ubuntu0.1)
Remove: libcuda1-340:amd64 (340.93-0ubuntu0.1), nvidia-340:amd64 (340.93-0ubuntu0.1), nvidia-opencl-icd-340:amd64 (340.93-0ubuntu0.1)
End-Date: 2015-10-29 09:36:11
bdmurray@clean-vivid-amd64:~$ apt-cache policy software-properties-gtk
software-properties-gtk:
  Installed: 0.96.4.1
  Candidate: 0.96.4.1
  Version table:
 *** 0.96.4.1 0
        500 http://192.168.10.7/ubuntu/ vivid-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.96.4 0
        500 http://192.168.10.7/ubuntu/ vivid/main amd64 Packages

description: updated
tags: added: verification-done-vivid
removed: verification-needed-vivid
Brian Murray (brian-murray) wrote :

I've verified this is in Trusty.

bdmurray@clean-trusty-amd64:~$ apt-cache policy software-properties-gtk
software-properties-gtk:
  Installed: 0.92.37.6
  Candidate: 0.92.37.6
  Version table:
 *** 0.92.37.6 0
        500 http://192.168.10.7/ubuntu/ trusty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.92.37.5 0
        500 http://192.168.10.7/ubuntu/ trusty-updates/main amd64 Packages
     0.92.36 0
        500 http://192.168.10.7/ubuntu/ trusty/main amd64 Packages
bdmurray@clean-trusty-amd64:~$ tail /var/log/apt/history.log

Start-Date: 2015-10-29 09:48:57
Commandline: apt-get install gir1.2-umockdev-1.0 umockdev
Install: umockdev:amd64 (0.8.1-1), gir1.2-umockdev-1.0:amd64 (0.8.1-1), libumockdev0:amd64 (0.8.1-1, automatic)
End-Date: 2015-10-29 09:48:58

Start-Date: 2015-10-29 09:50:26
Commandline: aptdaemon role='role-commit-packages' sender=':1.81'
Install: fakeroot:amd64 (1.20-3ubuntu2, automatic), screen-resolution-extra:amd64 (0.17.1, automatic), lib32gcc1:amd64 (4.9.1-0ubuntu1, automatic), dkms:amd64 (2.2.0.3-1.1ubuntu5.14.04.5, automatic), nvidia-settings:amd64 (331.20-0ubuntu8, automatic), libcuda1-340:amd64 (340.93-0ubuntu0.0.1, automatic), nvidia-340:amd64 (340.93-0ubuntu0.0.1), nvidia-libopencl1-340:amd64 (340.93-0ubuntu0.0.1, automatic), bbswitch-dkms:amd64 (0.7-2ubuntu1, automatic), nvidia-opencl-icd-340:amd64 (340.93-0ubuntu0.0.1, automatic), libfakeroot:amd64 (1.20-3ubuntu2, automatic), nvidia-prime:amd64 (0.6.2, automatic), nvidia-340-uvm:amd64 (340.93-0ubuntu0.0.1, automatic), libc6-i386:amd64 (2.19-0ubuntu6.6, automatic), libvdpau1:amd64 (0.7-1ubuntu0.1, automatic)
End-Date: 2015-10-29 09:51:36
bdmurray@clean-trusty-amd64:~$ apt-cache policy linux-generic
linux-generic:
  Installed: 3.13.0.67.73
  Candidate: 3.13.0.67.73
  Version table:
 *** 3.13.0.67.73 0
        500 http://192.168.10.7/ubuntu/ trusty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.13.0.66.72 0
        500 http://192.168.10.7/ubuntu/ trusty-updates/main amd64 Packages
        500 http://192.168.10.7/ubuntu/ trusty-security/main amd64 Packages
     3.13.0.24.28 0
        500 http://192.168.10.7/ubuntu/ trusty/main amd64 Packages

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.13.1

---------------
software-properties (0.96.13.1) wily-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden> Fri, 23 Oct 2015 10:58:33 -0700

Changed in software-properties (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-properties has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.37.6

---------------
software-properties (0.92.37.6) trusty-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden> Tue, 27 Oct 2015 16:56:42 -0700

Changed in software-properties (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.4.1

---------------
software-properties (0.96.4.1) vivid-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden> Tue, 27 Oct 2015 16:49:00 -0700

Changed in software-properties (Ubuntu Vivid):
status: Fix Committed → Fix Released

I am running UBUNTU Trusty 14.04.1 LTS as my OS. I am not running UBUNTU 15.10 ubiquity.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers