add-apt-repository crashed with IndexError in mangle_ppa_shortcut(): string index out of range

Bug #1426933 reported by milan cvijanovic on 2015-03-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Brian Murray
Vivid
Medium
Unassigned

Bug Description

from terminal try to add repository

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: software-properties-common 0.96.4
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 1 18:16:57 2015
ExecutablePath: /usr/bin/add-apt-repository
InstallationDate: Installed on 2015-03-01 (0 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150224)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/add-apt-repository ppa:/gottcode/gcppa
PythonArgs: ['/usr/bin/add-apt-repository', 'ppa:/gottcode/gcppa']
SourcePackage: software-properties
Title: add-apt-repository crashed with IndexError in mangle_ppa_shortcut(): string index out of range
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Changed in software-properties (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I was able to recreate this on wily.

tags: added: wily
Brian Murray (brian-murray) wrote :

The problem is the leading slash in the PPA name and there are surprising number occurrences of this at errors.ubuntu.com.

https://errors.ubuntu.com/bucket/?id=/usr/bin/add-apt-repository%3AIndexError%3A/usr/bin/add-apt-repository%40119%3Ashortcut_handler%3Ashortcut_handler%3A__init__%3Amangle_ppa_shortcut

The instructions for adding a PPA on Launchpad don't display a leading slash but it still seems worth fixing.

Changed in software-properties (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in software-properties (Ubuntu Vivid):
importance: Undecided → Medium
status: New → Triaged
Changed in software-properties (Ubuntu Vivid):
milestone: none → vivid-updates
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.13

---------------
software-properties (0.96.13) wily; urgency=medium

  * Properly parse a ppa which has a leading slash, something which a lot of
    people seem use as an argument to add-apt-repository. (LP: #1426933)

 -- Brian Murray <email address hidden> Tue, 13 Oct 2015 11:31:14 -0700

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Changed in software-properties (Ubuntu Vivid):
status: Triaged → Invalid
Changed in software-properties (Ubuntu Vivid):
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers