add-apt-repository hits softwareproperties.ppa.PPAException when trying to add a ppa which doesn't exist

Bug #1372086 reported by BavarianPH on 2014-09-21
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned

Bug Description

???

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: software-properties-common 0.93.2
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sat Sep 20 15:36:23 2014
ExecutablePath: /usr/bin/add-apt-repository
InstallationDate: Installed on 2014-09-18 (3 days ago)
InstallationMedia: Ubuntu-GNOME 14.10 "Utopic Unicorn" - Alpha amd64 (20140916)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/add-apt-repository ppa:gnome3
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/add-apt-repository', 'ppa:gnome3']
SourcePackage: software-properties
Title: add-apt-repository crashed with softwareproperties.ppa.PPAException in _get_https_content_py3(): 'Error reading https://launchpad.net/api/1.0/~gnome3: Not Found'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

BavarianPH (bavarianph) wrote :
tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
information type: Private → Public
summary: - add-apt-repository crashed with softwareproperties.ppa.PPAException in
- _get_https_content_py3(): 'Error reading
- https://launchpad.net/api/1.0/~gnome3: Not Found'
+ add-apt-repository hits softwareproperties.ppa.PPAException when trying
+ to add a ppa which doesn't exist
Changed in software-properties (Ubuntu):
importance: Medium → High
Sebastien Bacher (seb128) wrote :

that's easy to hit, just try to add a non existing ppa, e.g "sudo add-apt-repository ppa:user/name"

software-properties used to handle that correctly in trusty and display an message about the invalid ppa rather than an exception

https://errors.ubuntu.com/problem/f6de606db06b9ec0df787f3e055c073d2aa8e4b4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.13

---------------
software-properties (0.96.13) wily; urgency=medium

  * Properly parse a ppa which has a leading slash, something which a lot of
    people seem use as an argument to add-apt-repository. (LP: #1426933)

 -- Brian Murray <email address hidden> Tue, 13 Oct 2015 11:31:14 -0700

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers