cloud-archive:juno unsupported

Bug #1350291 reported by James Page on 2014-07-30
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
James Page
Trusty
High
James Page
Utopic
Undecided
James Page

Bug Description

SRU info

[Impact]
OpenStack users on 14.04 who which to use the Juno cloud archive can't use the normal route for enabling this additional pocket.

[Test Case]
sudo add-apt-repository cloud-archive:juno

[Regression Potential]
Minimal - changes are in utopic already and are scoped in the cloud-archive handler.

[Original Bug Report]
For 14.04, we'll be backporting OpenStack Juno using the Ubuntu Cloud Archive; we already support the existing 12.04 cloud archives using cloud-archive prefix; please add support for Juno on 14.04

James Page (james-page) on 2014-07-30
Changed in software-properties (Ubuntu Utopic):
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu Trusty):
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.93.2

---------------
software-properties (0.93.2) utopic; urgency=medium

  * Add pyflakes to autopkgtest dependencies.
 -- Colin Watson <email address hidden> Tue, 16 Sep 2014 21:03:42 +0100

Changed in software-properties (Ubuntu Utopic):
status: Confirmed → Fix Released
James Page (james-page) wrote :

SRU uploaded to trusty-proposed for SRU team review.

Thanks!

description: updated
Changed in software-properties (Ubuntu Trusty):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → James Page (james-page)

Hello James, or anyone else affected,

Accepted software-properties into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-properties/0.92.37.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Matteo Panella (mpanella) wrote :

I can confirm that software-properties 0.92.37.2 fixes the original issue on trusty, leaving "verification-needed" as-is since I performed only limited testing for the issue at hand.

Tom Fifield (fifieldt) wrote :
Download full text (3.3 KiB)

Works as advertised!

fifieldt@compute:~$ dpkg -l python-software-properties
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=============================-===================-===================-================================================================
ii python-software-properties 0.92.37.1 all manage the repositories that you install software from
fifieldt@compute:~$ sudo add-apt-repository cloud-archive:juno
'juno': not a valid cloud-archive name.
Must be one of ['folsom', 'folsom-proposed', 'grizzly', 'grizzly-proposed', 'havana', 'havana-proposed', 'icehouse', 'icehouse-proposed', 'tools', 'tools-proposed']
$ sudo apt-get install python3-software-properties=0.92.37.2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  software-properties-common
The following packages will be upgraded:
  python3-software-properties software-properties-common
2 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
Need to get 28.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-proposed/main software-properties-common all 0.92.37.2 [9,386 B]
Get:2 http://us.archive.ubuntu.com/ubuntu/ trusty-proposed/main python3-software-properties all 0.92.37.2 [19.2 kB]
Fetched 28.6 kB in 1s (24.8 kB/s)
(Reading database ... 95956 files and directories currently installed.)
Preparing to unpack .../software-properties-common_0.92.37.2_all.deb ...
Unpacking software-properties-common (0.92.37.2) over (0.92.37.1) ...
Preparing to unpack .../python3-software-properties_0.92.37.2_all.deb ...
Unpacking python3-software-properties (0.92.37.2) over (0.92.37.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up python3-software-properties (0.92.37.2) ...
Setting up software-properties-common (0.92.37.2) ...
fifieldt@compute:~$ sudo add-apt-repository cloud-archive:juno
 Ubuntu Cloud Archive for OpenStack Juno
 More info: https://wiki.ubuntu.com/ServerTeam/CloudArchive
Press [ENTER] to continue or ctrl-c to cancel adding it

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  ubuntu-cloud-keyring
0 upgraded, 1 newly installed, 0 to remove and 44 not upgraded.
Need to get 5,086 B of archives.
After this operation, 34.8 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/universe ubuntu-cloud-keyring all 2012.08.14 [5,086 B]
Fetched 5,086 B in 0s (7,152 B/s)
Selecting previously unselected package ubuntu-cloud-keyring.
(Reading database ... 95956 files and directories currently installed.)
Preparing to unpack .../ubuntu-cloud-keyring_2012.08.14_all.deb ...
Unpacking ubuntu-cloud-keyring (2012.08.14) ...
Setting up ubuntu-cloud-keyring (2012.08.14) ...
Importing ub...

Read more...

Tom Fifield (fifieldt) wrote :

As per arges' message, I'm going to change the tag to verification-done since the new package fixes the original issue.

tags: added: verification-done
removed: verification-needed
Chris J Arges (arges) on 2014-10-28
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.37.2

---------------
software-properties (0.92.37.2) trusty-proposed; urgency=medium

  * cloudarchive: Teach cloud-archive: prefix which Ubuntu Cloud Archive's
    map to which Ubuntu releases, adding support for Juno on 14.04
    (LP: #1350291).
  * cloudarchive: Tidy messages to have correct capitalization.
 -- James Page <email address hidden> Wed, 15 Oct 2014 17:03:23 +0100

Changed in software-properties (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-properties has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers