/usr/bin/software-properties-kde crashed when triggering mirror selection and clicking ok quickly

Bug #1307170 reported by KDEUSER56 on 2014-04-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Software Properties
Fix Released
Undecided
Unassigned
software-properties (Ubuntu)
High
Rohan Garg

Bug Description

See https://docs.google.com/file/d/0B-ihXi2hkCPfMGlCbnpyU2syYXc/edit?pli=1

Backtrace:

#0 0x00007f3d0fd36fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f3d0c2b1fe4 in g_main_context_poll (priority=2147483647, n_fds=2, fds=0x7f3cf40034b0, timeout=-1, context=0x7f3cf40009c0) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:4028
#2 g_main_context_iterate (context=context@entry=0x7f3cf40009c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3729
#3 0x00007f3d0c2b20ec in g_main_context_iteration (context=0x7f3cf40009c0, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#4 0x00007f3d0c71b7be in QEventDispatcherGlib::processEvents (this=0x7f3cf40008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5 0x00007f3d0c6ed0af in QEventLoop::processEvents (this=this@entry=0x7f3cf94e5e60, flags=...) at kernel/qeventloop.cpp:149
#6 0x00007f3d0c6ed3a5 in QEventLoop::exec (this=this@entry=0x7f3cf94e5e60, flags=...) at kernel/qeventloop.cpp:204
#7 0x00007f3d0c5e9c5f in QThread::exec (this=this@entry=0x2e52190) at thread/qthread.cpp:537
#8 0x00007f3d0c6ce823 in QInotifyFileSystemWatcherEngine::run (this=0x2e52190) at io/qfilesystemwatcher_inotify.cpp:265
#9 0x00007f3d0c5ec32f in QThreadPrivate::start (arg=0x2e52190) at thread/qthread_unix.cpp:349
#10 0x00007f3d10017182 in start_thread (arg=0x7f3cf94e6700) at pthread_create.c:312
#11 0x00007f3d0fd4430d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f3d10428740 (LWP 4570)):
[KCrash Handler]
#6 QWidget::~QWidget (this=0x2dd66b0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1632
#7 0x00007f3d0b74abc9 in ?? () from /usr/lib/python3/dist-packages/PyQt4/QtGui.cpython-34m-x86_64-linux-gnu.so
#8 0x00007f3d0b70277e in ?? () from /usr/lib/python3/dist-packages/PyQt4/QtGui.cpython-34m-x86_64-linux-gnu.so
#9 0x00007f3d0bc0a486 in ?? () from /usr/lib/python3/dist-packages/sip.cpython-34m-x86_64-linux-gnu.so
#10 0x00007f3d0bc0b659 in ?? () from /usr/lib/python3/dist-packages/sip.cpython-34m-x86_64-linux-gnu.so
#11 0x000000000046bbe2 in subtype_dealloc.16050 (self=0x7f3d0128c708) at ../Objects/typeobject.c:1172
#12 0x0000000000431980 in dict_dealloc.9974 (mp=0x7f3d0ed50bc8) at ../Objects/dictobject.c:1383
#13 0x000000000046bce9 in subtype_dealloc.16050 (self=0x7f3d01293b00) at ../Objects/typeobject.c:1157
#14 0x0000000000454b2b in insertdict.10035 (mp=mp@entry=0x7f3d1038a348, key=key@entry=0x7f3d102a9848, hash=2785936968932569566, value=0x9def60 <_Py_NoneStruct>) at ../Objects/dictobject.c:823
#15 0x0000000000454dca in PyDict_SetItem (op=op@entry=0x7f3d1038a348, key=key@entry=0x7f3d102a9848, value=<optimized out>) at ../Objects/dictobject.c:1207
#16 0x00000000004ac48a in _PyModule_ClearDict (d=0x7f3d1038a348) at ../Objects/moduleobject.c:353
#17 0x00000000005bf6ed in _PyModule_Clear (m=0x7f3d103894a8) at ../Objects/moduleobject.c:304
#18 PyImport_Cleanup () at ../Python/import.c:515
#19 0x00000000005bf945 in Py_Finalize.part.6.32879 () at ../Python/pythonrun.c:616
#20 0x00000000005bfc7c in Py_Finalize () at ../Python/pythonrun.c:2714
#21 Py_Exit (sts=sts@entry=0) at ../Python/pythonrun.c:2712
#22 0x000000000041e5d9 in handle_system_exit.part.7 () at ../Python/pythonrun.c:1811
#23 0x00000000005bffc3 in handle_system_exit () at ../Python/pythonrun.c:1856
#24 PyErr_PrintEx (set_sys_last_vars=set_sys_last_vars@entry=1) at ../Python/pythonrun.c:1821
#25 0x000000000060c170 in PyErr_Print () at ../Python/pythonrun.c:1717
#26 PyRun_SimpleFileExFlags (fp=fp@entry=0x2588900, filename=<optimized out>, filename@entry=0x7f3d102a2cb0 "/usr/bin/software-properties-kde", closeit=closeit@entry=1, flags=flags@entry=0x7fff07fa85d0) at ../Python/pythonrun.c:1610
#27 0x000000000060d3ac in PyRun_AnyFileExFlags (flags=0x7fff07fa85d0, closeit=<optimized out>, filename=<optimized out>, fp=0x2588900) at ../Python/pythonrun.c:1292
#28 run_file (p_cf=0x7fff07fa85d0, filename=0x2520200 L"/usr/bin/software-properties-kde", fp=0x2588900) at ../Modules/main.c:319
#29 Py_Main (argc=argc@entry=5, argv=argv@entry=0x251e010) at ../Modules/main.c:751
#30 0x000000000041ec0d in main (argc=5, argv=<optimized out>) at ../Modules/python.c:69

Despite having -dbg or if not available -dbgsy packages of the package containing /usr/lib/python3/dist-packages/sip.cpython-34m-x86_64-linux-gnu.so (its python3-sip) and /usr/lib/python3/dist-packages/PyQt4/QtGui.cpython-34m-x86_64-linux-gnu.so (its python3-pyqt4) (found via apt-file) I still get ?? ... normally this should not happen ...

Furthermore I noticed that I can install both, python3.4-dbgsym and python3.4-dbg which should normally conflict and also python-qt4-dbg and python-qt4-dbgsym can be installed in paralell ... how is this possible? (Anyway the backtrace does not become better)

Steps to Reproduce:
It does not happen every time, but it will happen for sure if you repeat the following steps if it does not crash (and you have to press "Ok" pretty quick)

1. Open "Configure Software Sources" in Moun
2. Trigger the mirror drop down and hover over the options
3. Press "ok" after loosing the focus of the dropdown

Related branches

Download full text (5.2 KiB)

#0 0x00007f3d0fd36fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f3d0c2b1fe4 in g_main_context_poll (priority=2147483647, n_fds=2, fds=0x7f3cf40034b0, timeout=-1, context=0x7f3cf40009c0) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:4028
#2 g_main_context_iterate (context=context@entry=0x7f3cf40009c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3729
#3 0x00007f3d0c2b20ec in g_main_context_iteration (context=0x7f3cf40009c0, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#4 0x00007f3d0c71b7be in QEventDispatcherGlib::processEvents (this=0x7f3cf40008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5 0x00007f3d0c6ed0af in QEventLoop::processEvents (this=this@entry=0x7f3cf94e5e60, flags=...) at kernel/qeventloop.cpp:149
#6 0x00007f3d0c6ed3a5 in QEventLoop::exec (this=this@entry=0x7f3cf94e5e60, flags=...) at kernel/qeventloop.cpp:204
#7 0x00007f3d0c5e9c5f in QThread::exec (this=this@entry=0x2e52190) at thread/qthread.cpp:537
#8 0x00007f3d0c6ce823 in QInotifyFileSystemWatcherEngine::run (this=0x2e52190) at io/qfilesystemwatcher_inotify.cpp:265
#9 0x00007f3d0c5ec32f in QThreadPrivate::start (arg=0x2e52190) at thread/qthread_unix.cpp:349
#10 0x00007f3d10017182 in start_thread (arg=0x7f3cf94e6700) at pthread_create.c:312
#11 0x00007f3d0fd4430d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f3d10428740 (LWP 4570)):
[KCrash Handler]
#6 QWidget::~QWidget (this=0x2dd66b0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1632
#7 0x00007f3d0b74abc9 in ?? () from /usr/lib/python3/dist-packages/PyQt4/QtGui.cpython-34m-x86_64-linux-gnu.so
#8 0x00007f3d0b70277e in ?? () from /usr/lib/python3/dist-packages/PyQt4/QtGui.cpython-34m-x86_64-linux-gnu.so
#9 0x00007f3d0bc0a486 in ?? () from /usr/lib/python3/dist-packages/sip.cpython-34m-x86_64-linux-gnu.so
#10 0x00007f3d0bc0b659 in ?? () from /usr/lib/python3/dist-packages/sip.cpython-34m-x86_64-linux-gnu.so
#11 0x000000000046bbe2 in subtype_dealloc.16050 (self=0x7f3d0128c708) at ../Objects/typeobject.c:1172
#12 0x0000000000431980 in dict_dealloc.9974 (mp=0x7f3d0ed50bc8) at ../Objects/dictobject.c:1383
#13 0x000000000046bce9 in subtype_dealloc.16050 (self=0x7f3d01293b00) at ../Objects/typeobject.c:1157
#14 0x0000000000454b2b in insertdict.10035 (mp=mp@entry=0x7f3d1038a348, key=key@entry=0x7f3d102a9848, hash=2785936968932569566, value=0x9def60 <_Py_NoneStruct>) at ../Objects/dictobject.c:823
#15 0x0000000000454dca in PyDict_SetItem (op=op@entry=0x7f3d1038a348, key=key@entry=0x7f3d102a9848, value=<optimized out>) at ../Objects/dictobject.c:1207
#16 0x00000000004ac48a in _PyModule_ClearDict (d=0x7f3d1038a348) at ../Objects/moduleobject.c:353
#17 0x00000000005bf6ed in _PyModule_Clear (m=0x7f3d103894a8) at ../Objects/moduleobject.c:304
#18 PyImport_Cleanup () at ../Python/import.c:515
#19 0x00000000005bf945 in Py_Finalize.part.6.32879 () at ../Python/pythonrun.c:616
#20 0x00000000005bfc7c in Py_Finalize () at ../Python/pythonrun.c:2714
#21 Py_Exit (sts=sts@entry=0) at ../Python/pythonrun.c:2712
#22 0x000000000041e5d9 in handle_system_exit.part.7 () at ../Pytho...

Read more...

Paul White (paulw2u) wrote :

I think I'm seeing the same problem but want to emphasise that it doesn't happen every time.

If I change between the main server and UK server the update normally happens but twice in the last five minutes I've seen the crash you report. On that basis I'll confirm the bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2014-04-13
tags: added: kubuntu
Changed in software-properties:
importance: Unknown → High
status: Unknown → New
Rohan Garg (rohangarg) on 2014-04-13
Changed in software-properties:
importance: High → Undecided
Changed in software-properties (Ubuntu):
milestone: none → ubuntu-14.04
assignee: nobody → Rohan Garg (rohangarg)
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.36

---------------
software-properties (0.92.36) trusty; urgency=medium

  * software-properties-kde : Work around crash in sip by skipping the
    + destructors of SIP objects. (LP: #1307170)
 -- Rohan Garg <email address hidden> Mon, 14 Apr 2014 11:36:13 +0200

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
Paul White (paulw2u) wrote :

Cleaning up by marking fixed.

Changed in software-properties:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.