software-properties does not recognize Nvidia Optimus hardware

Bug #1268750 reported by Sergio Benjamim on 2014-01-13
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Alberto Milone

Bug Description

Software-properties does not recognize Nvidia Optimus hardware, though the system so.

The expected was to appear some options, like:

- nvidia driver + nvidia-prime
- nvidia driver + bumblebee

Or just some nvidia drivers (304, 304-updates, 331, 331-updates...), as usual.

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

lsmod | grep nouveau
nouveau 1092248 1
mxm_wmi 13021 1 nouveau
ttm 84910 1 nouveau
i2c_algo_bit 13413 2 i915,nouveau
drm_kms_helper 52758 2 i915,nouveau
drm 302631 6 ttm,i915,drm_kms_helper,nouveau
video 19421 3 i915,nouveau,asus_wmi
wmi 19177 3 mxm_wmi,nouveau,asus_wmi

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: software-properties-common 0.92.31
ProcVersionSignature: Ubuntu 3.13.0-2.17-generic 3.13.0-rc7
Uname: Linux 3.13.0-2-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CasperVersion: 1.336ubuntu1
Date: Mon Jan 13 21:43:26 2014
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140113)
PackageArchitecture: all
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1268750

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
neon1ks (neon1ks) wrote :

In Ubuntu 13.10 32 bit

File type: image/png - http://ubuntuone.com/5ee9sHpbBfFG0LKyXgqkyw

$ sudo hybrid-detect
No gfx change

$ sudo nvidia-detector
none

$ lspci -k | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev ff)

Sashk0 (sashak-perm) wrote :

Сonfirm! I have the same problem as neon1ks

Changed in software-properties (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
status: Confirmed → In Progress
Dmitry (grayscale) wrote :

Ubuntu 13.04, Ubuntu 13.10 64bit
The same as neon1ks

$ lspci -k | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 740M] (rev ff)

$ sudo hybrid-detect
No gfx change

$ sudo nvidia-detector
none

Nicola Diapoli (nicodina) wrote :

Ubuntu 13.10 64bit
Same of Dmitry and neon1ks

$ lspci -k | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)

$ sudo hybrid-detect
No gfx change

$ sudo nvidia-detector
none

Sergio Benjamim (sergio-br2) wrote :

software-properties is recognizing Nvidia now, at least in my hardware (but only after system install, in the Live system it does not)

LE BIDEAU (elbc) wrote :

any knews on this issue ? I'm struggling with this. Newly bought an Asus laptop (pu551dj) and no way to find how to make it works (nvidia). Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers