[kde] software-properties-kde does not check if apt lines are valid

Bug #116445 reported by Julian Olivien on 2007-05-23
12
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-properties-kde

The Software Properties dialog used Kubuntu Feisty's adept does not seem to check whether an apt line added under "Third-Party-Software" is valid, but simply adds everything you enter as a new line in sources.list. The consequence is that sources.list is messed up and fetching updates fails.

it would be a good idea to introduce a mechanism that checks validity of added repository-lines and a notification which tells the user to change a malformed line before adding it.

Related branches

Scott Kitterman (kitterman) wrote :

Do you have a proposal for an algorithm to do this?

Changed in software-properties:
importance: Undecided → Wishlist
status: Unconfirmed → Needs Info
Julian Olivien (julianolivien) wrote :

no, not really, but two ideas come into my mind:

1. check if the line has three spaces, if the first word is deb or deb-src and if the second word is a url. (may not fix any case)

2. find out on what basis apt-get update decides if it throws out an error about a malformed sources.list (should fix every possible problem)

Sebastian Heinlein (glatzor) wrote :

aptsources already provides such a mechanism and this one is already used in the GTK frontend.

It only needs a QT/KDE hacker to port it from the GTK frontend.

Cheers,

Sebastian

Changed in software-properties:
status: Needs Info → Confirmed
Michael Vogt (mvo) on 2007-05-24
Changed in software-properties:
importance: Wishlist → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.5

---------------
software-properties (0.75.5) lucid; urgency=low

  [ Harald Sitter ]
  * KDE frontend: replace old manual listing of file endings for key import
    with mimetype based model (no need to support old stuff since it is so
    incredibly wrong... ending-wise that is)

  [ Amichai Rothman ]
  * Fix import of keys with non-ascii filename (LP: #350485)
  * Add source line input validation when adding a new source (LP: #116445)
  * Fix selected item and edit/remove button state after toggling a source
  * Fix alternate mirror selection corrupting sources.list (LP: #464707)
  * Fix selected mirror not shown in combobox (LP: #96110)
  * Fix mirror selection dialog error in non-ascii locale (LP: #96201)
  * Fix crash when modifying sources selection (LP: #102792)
  * Fix error handling when ppa key is missing (LP: #475220)
  * Improve keyboard tab order in some dialogs (LP: #464569)
  * Fix and improve mirror test and GUI (LP: #223047)
  * Fix mirror test timeout handling (LP: #456365)
  * Fix i18n, accelerators and styling on all dialogs (LP: #102773)
  * Fix utf8 in edit source dialog comments (LP: #489960)
 -- Amichai Rothman <email address hidden> Mon, 07 Dec 2009 14:46:38 +0200

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
amichair (amichai2) wrote :

Note that the fix uses aptsources validation just like the gtk frontend does, as suggested above, but the aptsources validation is not perfect - see Bug #496156.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers