Software-properties mirror selection may pick an out-of-date mirror

Bug #1068422 reported by Arup on 2012-10-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned

Bug Description

Trying to install skype in Ubuntu Quantal gives skype-bin error in software center.

Steve Langasek (vorlon) wrote :

Could you please show the output of the following command run from a terminal?

  apt-cache policy skype-bin

Changed in skype (Ubuntu):
status: New → Incomplete
Arup (arup-chowdhury) wrote :

skype-bin:i386:
  Installed: (none)
  Candidate: 4.0.0.8-0oneiric1
  Version table:
     4.0.0.8-0oneiric1 0
        500 http://archive.canonical.com/ubuntu/ quantal/partner i386 Packages

On Fri, Oct 19, 2012 at 04:03:33AM -0000, Arup wrote:
> skype-bin:i386:
> Installed: (none)
> Candidate: 4.0.0.8-0oneiric1
> Version table:
> 4.0.0.8-0oneiric1 0
> 500 http://archive.canonical.com/ubuntu/ quantal/partner i386 Packages

Thanks. If you try to install skype from the commandline by running this
command, does it succeed?:

  sudo apt-get install skype

Nope I get the following message.

arup@arup-K53E:~$ sudo apt-get install skype
[sudo] password for arup:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Steve Langasek (vorlon) wrote :

How about the output of this command:

  sudo apt-get install skype skype-bin

Arup (arup-chowdhury) wrote :

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqt4-network:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqtcore4:i386 (>= 4:4.6.1) but it is not going to be installed
                  Depends: libqtgui4:i386 (>= 4:4.6.1) but it is not going to be installed
                  Recommends: sni-qt:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

please run
"apport-collect 1068422"
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Arup (arup-chowdhury) wrote :

If I run that command I get

arup@arup-K53E:~$ apport-collect 1068422
ERROR: The launchpadlib Python module is not installed. This functionality is not available.

what if you try sudo apt-get install libqt4-dbus:i386

I cannot reproduce on quantal i386, maybe libqt4-dbus i386 breaks something on 64 bit environment (only in quantal)?

Arup (arup-chowdhury) wrote :

Yes it appears to be a x64 issue but ironically it works fine in 11.10 and 12.04 x64.

Marten Gorodetsky (askmarten) wrote :

I've got the same problem, also on 64 bit Ubuntu 12.10. I've scanned the forums and askubuntu for this problem and at least one other person affected by this bug used Wubi to install Ubuntu which I did too, so this might be related if it should turn out that Arup also used Wubi since Skype seems to install fine for the majority of people.

On Fri, Oct 19, 2012 at 05:39:17AM -0000, Arup wrote:
> The following packages have unmet dependencies:
> skype-bin:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
> Depends: libqt4-network:i386 (>= 4:4.5.3) but it is not going to be installed
> Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
> Depends: libqtcore4:i386 (>= 4:4.6.1) but it is not going to be installed
> Depends: libqtgui4:i386 (>= 4:4.6.1) but it is not going to be installed
> Recommends: sni-qt:i386 but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.

So this probably indicates that you have local or outdated versions of some
packages installed. The following command should give a more detailed
explanation (*very* detailed, so you probably want to capture the output to
a file and post it to this bug):

 sudo apt-get -oDebug::pkgProblemResolver=true install skype

Output attached. I did not install from Wubi, in fact there is a thread in the Ubuntu forum where many people are having the same issue. My Ubuntu install is via the x64 ISO CD, I don't have any other OS on this machine.

Arup (arup-chowdhury) wrote :

http://ubuntuforums.org/showthread.php?t=2072421&highlight=skype

Here is the thread on Ubuntu forums describing the same issue.

Steve Langasek (vorlon) wrote :

The apt output shows:

Broken libcups2:amd64 Breaks on libcups2 [ i386 ] < none -> 1.6.1-0ubuntu10 > ( libs ) (!= 1.6.1-0ubuntu11)
  Considering libcups2:i386 3 as a solution to libcups2:amd64 33
  Added libcups2:i386 to the remove list
  Fixing libcups2:amd64 via keep of libcups2:i386
Investigating (0) libffi6 [ i386 ] < none -> 3.0.11-1 > ( libs )
Broken libffi6:i386 Breaks on libffi6 [ amd64 ] < 3.0.11-2 > ( libs ) (!= 3.0.11-1)
  Considering libffi6:amd64 5 as a solution to libffi6:i386 7
  Added libffi6:amd64 to the remove list
  Fixing libffi6:i386 via remove of libffi6:amd64

The i386 package list on your system is out of date, somehow, and is not showing the current versions of the library packages. Please show the output of 'apt-cache policy libcups2:i386'.

Arup (arup-chowdhury) wrote :

arup@arup-K53E:~$ apt-cache policy libcups2:i386
libcups2:i386:
  Installed: (none)
  Candidate: 1.6.1-0ubuntu10
  Version table:
     1.6.1-0ubuntu10 0
        500 http://ubuntuarchive.hnsdc.com/ubuntu/ quantal/main i386 Packages

Steve Langasek (vorlon) wrote :

Thanks. It appears your system is configured to use an unofficial mirror of Ubuntu which is out of date. Configuring your system to use an official mirror in the software properties will allow you to install the package. (alternatively, if this is a local mirror, you may want to talk to your system administrator about getting it updated.)

Changed in skype (Ubuntu):
status: Incomplete → Invalid
Arup (arup-chowdhury) wrote :

Thank you Steve, let me try the main mirrors and I will revert back.

Arup (arup-chowdhury) wrote :

Works beautifully, thank you very much. That mirror was selected when I used the find the fastest mirror, seems like it has not been synced properly.

Steve Langasek (vorlon) wrote :

Ah, I can confirm that the software-properties dialog lists this mirror. It's shown as "Last update unknown" on https://launchpad.net/ubuntu/+archivemirrors, but this doesn't seem to prevent it from being included in the search list. This may be a bug in the mirror list, which ought to prune mirrors that aren't up to date. python-apt hasn't been updated for a while anyway though, so fixing the list on the website wouldn't have helped. I think we need to regard this as a bug in software-properties; "Select Best Server" shouldn't give you a mirror that's demonstrably out of date.

affects: skype (Ubuntu) → software-properties (Ubuntu)
Changed in software-properties (Ubuntu):
importance: Undecided → High
status: Invalid → Confirmed
status: Confirmed → Triaged
summary: - Skype unable to install
+ Software-properties mirror selection may pick an out-of-date mirror
Arup (arup-chowdhury) wrote :

In fact all the mirrors in India seem to have this issue, I have since changed all my Ubuntu machines to main, now to do it at an institution mass level remains a challenge for me.

Marten Gorodetsky (askmarten) wrote :

Changing mirrors didn't do anything for me, but the forum thread Arup linked to had the fix for me. After doing:

    sudo dpkg --add-architecture i386
    sudo apt-get update

I was finally able to install skype with:

    sudo apt-get install skype

So it looks like even though I got the same error message my problem was different. This was on a fresh install of Ubuntu 12.10 x64 using Wubi and I didn't do anything other than adding the Canonical Partners repository before trying to install Skype.

Mikhail (mikhail-g) wrote :

Got the same issue on 12.04 x64: can not install skype(attached skype installation log).

Skype was removed when I have upgraded from 10.04 to 12.04 so I tied to reinstall it with:

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

and got this:

glaz@glaz:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

I have also tried to download Skype package from official Skype website and install packege via dpkg -i, but installation have failed because my system does not contain ia32-libs package... and I can not install it too..

I have googled for such problems and decided to reinstall Ubuntu from my LiveUSB 12.04 x64 but it doesn't make sense, I still have the same errors. Looks like I can not install any i386 packages at all =( (I already meant about ia32-libs).

As you may see in attached file, I've already manually switched to main ubuntu mirror, but it doesn't make sense too.
Also, I have tried to manually add "foreign-architecture i386" to /etc/dpkg/dpkg.cfg.d/multiarch but nothing changed.
Any ideas on possible solutions?

Mikhail (mikhail-g) wrote :

I've reinstalled from scratch again.
Just formatted partition that was dedicated for '/' mounting and also renamed my old home directory before reinstallation.
And now everything works and installs fine. So I believe my troubles was caused by some old configs or something like that.

webmarwell (webmarwell) wrote :

I can confirm this bug. apt-get install skype > needs skype-bin but it is a virtual package.
apt-get install skype skype-bin (translated from my german output) >
skype-bin:i386 :
depends: libqt4-dbus:i386 (>= 4:4.5.3) ...
depends: libqt4-network:i386 (>= 4:4.8.0) ...
depends: libqt4-xml:i386 (>= 4:4.5.3) ...
depends: libqtcore4:i386 (>= 4:4.7.0~beta1) ...
depends: libqtgui4:i386 (>= 4:4.8.0) ...
depends: libqtwebkit4:i386 (>= 2.2~2011week36)
All those cannot be installed.

Kubuntu 12.10, KDE 4.9.3 (Kubuntu-Updates), Ubuntu-Partner-Repository

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers