Ubuntu

Software-properties-gtk does not start

Reported by Roland (Rolandixor) Taylor on 2012-09-23
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
Unassigned
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

Here's the command line output:

Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 37, in <module>
    from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 34, in <module>
    from aptdaemon import client
EOFError: EOF read where not expected

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-properties-gtk 0.92.6
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Sun Sep 23 17:03:00 2012
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: Upgraded to quantal on 2010-01-19 (977 days ago)

Edward Donovan (edward.donovan) wrote :

(I can't reproduce this yet.) I'm not yet sure if this is an exact dupe of bug 1055055, but that is the same error happening from update-manager. It may be aptdaemon's bug. Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in software-properties (Ubuntu):
status: New → Confirmed
progre55 (progre55) wrote :

Getting the same error running:

$ software-properties-gtk
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 37, in <module>
    from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk
EOFError: EOF read where not expected

as for the bug 1055055 (update-manager), just running update-manager is fine, but when you try to open "Settings", it tries calling software-properties-gtk:

$ update-manager
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 37, in <module>
    from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk
EOFError: EOF read where not expected

Edvinas (ikonitas) wrote :

Same Error:

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 114, in <module>
    app = UpdateManager(data_dir, options)
  File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 75, in __init__
    self.unity = UnitySupport()
  File "/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py", line 58, in __init__
    um_launcher_entry = Unity.LauncherEntry.get_for_desktop_id(
  File "/usr/lib/python3/dist-packages/gi/module.py", line 269, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib/python3/dist-packages/gi/module.py", line 164, in __getattr__
    interfaces = tuple(interface for interface in get_interfaces_for_object(info)
  File "/usr/lib/python3/dist-packages/gi/module.py", line 89, in get_interfaces_for_object
    module = __import__('gi.repository.%s' % namespace, fromlist=[name])
  File "/usr/lib/python3/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python3/dist-packages/gi/module.py", line 244, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
EOFError: EOF read where not expected

Sebastian Heinlein (glatzor) wrote :

It seems that you have got some file system issues on your system. Please try to re-install the python3-gi package

Changed in software-properties (Ubuntu):
status: Confirmed → Invalid
Changed in aptdaemon (Ubuntu):
status: Confirmed → Invalid

I no longer have this problem actually. Forgot to mark it otherwise before.

Philip Morby (p-morby) wrote :

I am seeing the same issue and have so far tried reinstalling: python3-apport software-properties-gtk python3-gi

Changed in aptdaemon (Ubuntu):
status: Invalid → New
status: New → Incomplete
Changed in software-properties (Ubuntu):
status: Invalid → New
Changed in aptdaemon (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers