software-properties-gtk crashed with OSError in _execute_child(): [Errno 2] No such file or directory: '/usr/lib/indicator-session/gtk-logout-helper'

Bug #1041410 reported by Shanekpiper on 2012-08-25
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Session Menu
Invalid
Undecided
Unassigned
indicator-session (Ubuntu)
Undecided
Unassigned
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

tried to restart as additonal drivers said to

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: software-properties-gtk 0.91
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Sat Aug 25 01:27:52 2012
ExecutablePath: /usr/bin/software-properties-gtk
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120819)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.2 /usr/bin/software-properties-gtk
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
PythonArgs: ['/usr/bin/software-properties-gtk']
SourcePackage: software-properties
Title: software-properties-gtk crashed with OSError in _execute_child(): [Errno 2] No such file or directory: '/usr/lib/indicator-session/gtk-logout-helper'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Shanekpiper (shanekpiper) wrote :
tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I am adding indicator-session to this bug since I think indicator-session should do what glib2.0 does.

/usr/bin/glib-compile-schemas is a symlink to ../lib/x86_64-linux-gnu/glib-2.0/glib-compile-resources on my system. Therefore any problem that wants to call glib-compile-schemas (or gtk-logout-helper) could just call it and not have to worry about where it's actually installed.

visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) wrote :

If we decide to have it in /usr/bin (which is a good idea), it shouldn't start with "gtk-".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.1-0ubuntu3

---------------
indicator-session (12.10.1-0ubuntu3) quantal; urgency=low

  * debian/rules:
    - set libexecdir to a non multiarch location, other components look
      to the standard path for the logout dialog helper, that's a workaround
      until the binary is moved to bin (lp: #1041410)
 -- Sebastien Bacher <email address hidden> Mon, 27 Aug 2012 15:15:49 +0200

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Packaging error, so this is invalid in upstream project.

Changed in indicator-session:
status: New → Fix Released
status: Fix Released → Invalid
Brian Murray (brian-murray) wrote :

This is fixed in at least Saucy where gnome-session-quit --reboot is called.

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers