Translations (i18n) broken in software-properties-kde

Bug #102773 reported by Sebastian Heinlein on 2007-04-04
112
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
software-properties (Ubuntu)
High
Harald Sitter

Bug Description

Although the German translation is complete, it is not used by the KDE frontend. Furthermore special characters are broken.

Related branches

Sebastian Heinlein (glatzor) wrote :

Screenshot of the issue.

Michael Vogt (mvo) on 2007-04-04
Changed in software-properties:
assignee: nobody → jr
importance: Undecided → Medium
Timo Jyrinki (timo-jyrinki) wrote :

Could you use the daily langpacks from http://people.ubuntu.com/~pitti/langpacks/daily/feisty/?

I updated from that repository and nothing to change.
IMHO, it's not a langpack's problem.

I cannot read...

Changed in software-properties:
status: Unconfirmed → Confirmed
Jonathan Riddell (jr) wrote :

Fixed in 0.59.4, needs accepted by release dude.

Changed in software-properties:
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

Accepted:
software-properties 0.59.4 was ACCEPTED.
        Component: main Section: admin

Changed in software-properties:
status: Fix Committed → Fix Released

Hello Jonathan, thank you for the time you invested in the numerous i18n issues in Kubuntu during the last weeks. Unfortunately this issue is only fixed partly. Now all special characters/umlauts (äöü) are displayed correctly, but the translation is still not used by the KDE frontend, although it is completly translated.

Changed in software-properties:
status: Fix Released → Confirmed

Any progress on this issue? A lot of strings in kde frontend still don't appear translated although we have a 100% translation in Rosetta...

It seems to still have a problem.

I am very sorry. above is mistaken.

It's the same for german - beside the translated parts ;-)

Alexandr_Gr (alexandr-gridnev) wrote :

same problem for russian

Same thing is in a Third-party tab.

This bug is stil present in Intrepid...

Savvas Radevic (medigeek) wrote :

Can you try with a daily live cd:
http://cdimage.ubuntu.com/kubuntu/daily-live/current/

In Greek and German it looks correct.

Savvas Radevic (medigeek) wrote :

The only thing I've noticed problematic is the server list in Greek

Savvas Radevic (medigeek) wrote :

Ah wait, now I get it, it looks as incomplete translation (and the server list problem).

Alexey Androsov (doochik) wrote :

Just try with latest live cd. The error is still present for russian

Savvas Radevic (medigeek) wrote :

Correct, just created a patch for it :)

Changed in software-properties:
assignee: jr → medigeek
status: Confirmed → In Progress
Savvas Radevic (medigeek) wrote :

Created test packages for it (0.71.2~ppajaunty1):
http://ppa.launchpad.net/medigeek/ppa/ubuntu/pool/main/s/software-properties/

Since the patch is for kde, you'll have to download:
- python-software-properties_0.71.2~ppajaunty1_all.deb
- software-properties-kde_0.71.2~ppajaunty1_all.deb

and install them in that order.

Changed in software-properties:
status: In Progress → Fix Committed
Alexey Androsov (doochik) wrote :

My problem is fixed after installing you packages!
Thank you very match!

Savvas Radevic (medigeek) wrote :

> My problem is fixed after installing you packages!
> Thank you very match!

Thanks for testing :)

About the seemingly incomplete translations:
> Although the German translation is complete, it is not used by the KDE frontend. Furthermore special characters are broken.

I think I know why! software-properties-kde as well as gdebi-kde seem to be using /usr/share/locale-langpackage :
http://packages.ubuntu.com/search?searchon=contents&keywords=software-properties.mo&mode=&suite=jaunty&arch=any

You should be translating those packages - or figure out where they come from. :)

Timo Jyrinki (timo-jyrinki) wrote :

Hi Savvas, your work looks great. Could you still do a bzr branch of https://code.launchpad.net/~ubuntu-core-dev/software-properties/main and put your branch with this fix committed on Launchpad? That way you could do a merge request for the core development team (unless you or someone else subscribed to this bug report are part of it of course ;)) and it would be a simple matter of pinging someone to pull the fix in.

Savvas Radevic (medigeek) wrote :

Timo, already done that! :) See "Related branches" and "Fix committed" status on top of the page

Timo Jyrinki (timo-jyrinki) wrote :

Right, my brains had some wrong filter mode on, but great stuff to see this finally getting fixed :)

Timo Jyrinki (timo-jyrinki) wrote :
Changed in software-properties:
status: Fix Committed → Fix Released
vista killer (vistakiller) wrote :

The problem is fixed with greek translate in most of the options. There is still one issue. You can see here in the pic

Alexey Androsov (doochik) wrote :

I have the same problem with russian

Changed in software-properties (Ubuntu):
assignee: medigeek → nobody
summary: - l10n broken in the KDE frontend
+ l10n broken in software-properties
Savvas Radevic (medigeek) wrote :

The software-properties "third party software" fix is reviewed and approved, it will be probably released with the next version of software-properties :)

usr (usrlp) wrote :

The patch doesn't fix the bug. Go to "Third-Party software", and write a description with non standard characters.
For example, the "ó" of "Código fuente" (source code) doesn't appear, a rare character appears instead of it.

I think the bug comes from above and should be resolved in the way to serve for any part of the program.

Changed in software-properties (Ubuntu):
status: Fix Released → Confirmed

2009/6/6 usr <email address hidden>:
> The patch doesn't fix the bug. Go to "Third-Party software", and write a description with non standard characters.
> For example, the "ó" of "Código fuente" (source code) doesn't appear, a rare character appears instead of it.

Sanity check:

1. Did you use:
a) the diff from
https://code.launchpad.net/~medigeek/software-properties/kde_deb_and_deb-src_unicode_fix/+merge/4956
?
*or*
b) the revision 558 from
https://code.launchpad.net/~ubuntu-core-dev/software-properties/main ?

2. Can you provide a screenshot?

3. Which release? jaunty 9.04?

> I think the bug comes from above and should be resolved in the way to
> serve for any part of the program.

"Código fuente" works in software-properties-gtk so the problem seems
to be to the way kde handles utf-8 (?).

1. I am using the patch that Kubuntu 9.04 includes (I don't know what patch is).
2. At the moment, no.
3. In software-properties-gtk, no problem.

Savvas Radevic (medigeek) wrote :
Savvas Radevic (medigeek) wrote :

> 1. I am using the patch that Kubuntu 9.04 includes (I don't know what patch is).

If you did not patch it, you did not use the patch. :)
Execute in Applications > Accessories > Terminal:

apt-cache policy software-properties-kde

If it says "Installed: 0.71.5" then you did not use the correct version. My patch is with the new package version 0.72 in karmic (future ubuntu 9.10).

You can download the deb packages for jaunty: http://launchpadlibrarian.net/27583193/software-properties-0.72.tar.gz

usr (usrlp) wrote :
usr (usrlp) wrote :
usr (usrlp) wrote :

Where are the deb packages?

usr (usrlp) wrote :

O.K. I just downloaded and installed the deb packages. The result:
- The bug of my first snapshot is still present.
- The bug of my second snapshot was solved.

user@machine:~$ apt-cache policy software-properties-kde
software-properties-kde:
  Instalados: 0.72~ppajaunty1
  Candidato: 0.72~ppajaunty1
  Tabla de versión:
 *** 0.72~ppajaunty1 0
        100 /var/lib/dpkg/status
     0.71.5 0
        500 http://es.archive.ubuntu.com jaunty/main Packages

usr (usrlp) wrote :

...and, in software-properties-gtk, no problem (like ever).

Savvas Radevic (medigeek) wrote :

Hm.. so the CD/DVD rom list needs a unicode tweak too. :)
I'll check it out later, if anyone wants to take this, please do!

Yeah. I said "O.K. I just downloaded and installed the deb packages."
Thank you anyway. :-)

usr (usrlp) wrote :

I don't know programming, but...

Don't it would be easier to make a general patch for the application instead of a patch for each area? Every time you create a new section will have to be patched?

> I don't know programming, but...
>
> Don't it would be easier to make a general patch for the application
> instead of a patch for each area? Every time you create a new section
> will have to be patched?

Yes it would, but I don't use KDE, so I entirely rely on what you
people find. :)
Have you noticed any other problems with utf-8?

In software-properties-kde, no.

Thanks for fixing UTF-8 issue. But software properties KDE still appears partially in English (French translation is complete in Launchpad) in Jaunty and Karmic

> partially in English (French translation is complete in Launchpad)
Bruno, talk to the ubuntu translators to update the language packages
and french translation of software-properties for karmic.

Try out the IRC channel:
http://webchat.freenode.net/?channels=ubuntu-translators

Le jeudi 30 juillet 2009 11:31:04, Savvas Radevic a écrit :
> > partially in English (French translation is complete in Launchpad)
>
> Bruno, talk to the ubuntu translators to update the language packages
> and french translation of software-properties for karmic.

This is not a translation issue. I have a complete French translation on my
computer and software-properties-kde appears partially in English.

> This is not a translation issue. I have a complete French translation on my
> computer and software-properties-kde appears partially in English.

I don't mean to be rude, but are you 100% sure you are using it correctly?
First of all the ubuntu the package is: language-pack-fr-base
If you have that package installed REPLACE this file:

/usr/share/locale-langpack/fr/LC_MESSAGES/software-properties.mo

..with your 100% translated file. It should be in .mo format (NOT .po).
If you don't have a .mo file, you can choose "MO format" and download it from here:
https://translations.launchpad.net/ubuntu/karmic/+source/software-properties/+pots/software-properties/fr/+export

Lastly, I was just checking out the translation status:
https://translations.launchpad.net/ubuntu/karmic/+source/software-properties/+pots/software-properties

As you can see in the attached screenshot, only 33% of the french translation is included (green colour), and about 44% is new and *not* packaged (purple colour).

Savvas Radevic (medigeek) wrote :

It seems you're right, I've asked for a template file update, the software-properties.pot seems outdated:
https://bugs.launchpad.net/bugs/407240

Thanks a lot for trying to solve this issue Savvas. I know how to deal with gettext templates.

I downloaded software-sources-075.1 (from karmic repo) source package and tried to examine the code. I really dont know much about Python, but I found some errors in SoftawarePropertiesKDE.py, for example to have the "Add source" dialog translated i had to modify those lines (653) :

    text = _('<p><b>Enter the complete APT line of the<br /> repository that you want to add as source</b></p><p>The APT line includes the type, location and components of a repository,<br /> for example <i>"%s"</i>.</p>') % example
    text=utf8(text)

There's also a problem in this file with translate-widget functions but I really don't understand how this could work.

HTH

tags: added: i18n kubuntu
removed: kubuntu-i18n
summary: - l10n broken in software-properties
+ Translations (i18n) broken in software-properties
summary: - Translations (i18n) broken in software-properties
+ Translations (i18n) broken in software-properties-kde
Adi Roiban (adiroiban) on 2009-10-31
Changed in ubuntu-translations:
importance: Undecided → Medium
status: New → Confirmed
Harald Sitter (apachelogger) wrote :

Partially fixed in bazaar branch ... not there yet, there are larger things at works than mere limitations of the KDE UI in this regard

Changed in software-properties (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Medium → High
milestone: ubuntu-7.04 → none
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.5

---------------
software-properties (0.75.5) lucid; urgency=low

  [ Harald Sitter ]
  * KDE frontend: replace old manual listing of file endings for key import
    with mimetype based model (no need to support old stuff since it is so
    incredibly wrong... ending-wise that is)

  [ Amichai Rothman ]
  * Fix import of keys with non-ascii filename (LP: #350485)
  * Add source line input validation when adding a new source (LP: #116445)
  * Fix selected item and edit/remove button state after toggling a source
  * Fix alternate mirror selection corrupting sources.list (LP: #464707)
  * Fix selected mirror not shown in combobox (LP: #96110)
  * Fix mirror selection dialog error in non-ascii locale (LP: #96201)
  * Fix crash when modifying sources selection (LP: #102792)
  * Fix error handling when ppa key is missing (LP: #475220)
  * Improve keyboard tab order in some dialogs (LP: #464569)
  * Fix and improve mirror test and GUI (LP: #223047)
  * Fix mirror test timeout handling (LP: #456365)
  * Fix i18n, accelerators and styling on all dialogs (LP: #102773)
  * Fix utf8 in edit source dialog comments (LP: #489960)
 -- Amichai Rothman <email address hidden> Mon, 07 Dec 2009 14:46:38 +0200

Changed in software-properties (Ubuntu):
status: Triaged → Fix Released
lsmod (forum+ubuntu) on 2010-05-02
Changed in ubuntu-translations:
status: Confirmed → New
lsmod (forum+ubuntu) wrote :

I installed Kubuntu 10.04 Lucid Lynx and the problem as described first is back.

I have choosen language german at the installation and later on i choose german everywhere in the language settings.
But this has no effect.
Some parts are in english and some parts in german.

Open Office is always in english.
I installed the package koffice-l10n-de but this has no effect.

On another PC Ubuntu 9 was already installed with the language correct in german.
There was no problem after the upgrade.

I also opened bug 573808 because there where problems with the locales on the shell.
https://bugs.launchpad.net/ubuntu-translations/+bug/

As example i attached a snapshot of the language settings.
Here you can see the settings and how the languages are mixed up.

David Planella (dpm) on 2010-08-02
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.