software-properties-gtk crashed with TypeError in set_release_upgrades_policy(): 'str' does not support the buffer interface

Bug #1021639 reported by Karoll Denoyel on 2012-07-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Colin Watson

Bug Description

Clean install with quantal 12.10 x64. Many bugs like with gnome and system settings. Don't know why, I did everything properly. It didn't turn this way with previous version of Ubuntu even if it's the first time I use a DVD (quantal) version.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: software-properties-gtk 0.86
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
ApportVersion: 2.2.5-0ubuntu2
Architecture: amd64
Date: Fri Jul 6 10:41:22 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/software-properties-gtk
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120612)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.2 /usr/bin/software-properties-gtk --open-tab 2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/software-properties-gtk', '--open-tab', '2']
SourcePackage: software-properties
Title: software-properties-gtk crashed with TypeError in set_release_upgrades_policy(): 'str' does not support the buffer interface
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Karoll Denoyel (denoyel-k) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2012-07-10
visibility: private → public
Changed in software-properties (Ubuntu):
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.87

---------------
software-properties (0.87) quantal; urgency=low

  * Restore apt-add-repository symlink.
  * Handle removal of cmp builtin from Python 3 (LP: #1022665).
  * Open NamedTemporaryFile in text mode when writing text to it
    (LP: #1021639).
  * Fix display glitch in add-apt-repository that caused "None" to be
    printed for any PPA without a description.
 -- Colin Watson <email address hidden> Tue, 10 Jul 2012 09:56:14 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers