package installation not notified

Bug #985756 reported by Sandra Farnedi on 2012-04-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

I can reproduce this *when* software-center-agent finishes exactly during the install of 2vcard

1. ensure "2vcard" is not installed
2. run software-center search:2vcard
3. click on "install"
4. wait for it to finish and notice that the listview screen is not updated and there is no "installed" emblem the button still says "install"

edubuntu usb live. italian version. I install CompizConfig Settings Manager. After a few minutes the screen appearence is the one shown in the first screen shot. When the installation ends, the situation is the one shown in the second screen-shot. I open CompizConfig Settings Manager and it works fine. I click on CompizConfig Settings Manager in software center windows and it seems not installed as you can see from the third screen-shot. I press install and the installation starts again. After a few minutes the Install button is converted into the Remove one.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CasperVersion: 1.315
Date: Thu Apr 19 18:48:30 2012
LiveMediaBuild: Edubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120419.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/985756

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Reproduced in a fresh installed system
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2012-04-23
Changed in software-center (Ubuntu):
importance: Undecided → Medium
milestone: none → precise-updates
description: updated
Changed in software-center (Ubuntu):
importance: Medium → High
Michael Vogt (mvo) on 2012-04-23
Changed in software-center (Ubuntu):
importance: High → Medium
Michael Vogt (mvo) on 2012-04-23
description: updated
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

If you can reproduce this, can you outline the steps? Can you also attach /var/log/apt/history.log /var/log/syslog and ~/.cache/software-center/software-center.log please?

Michael Vogt (mvo) wrote :

I can not reliable reproduce this, but I did manage to hit it. Its unclear to me at this point if its a race condition or if its random if there is a pattern. Any hints welcome!

Michael Vogt (mvo) wrote :

I can reproduce this with the branch "lp:~mvo/software-center/race-lp985756" when doing:
1. bzr get lp:~mvo/software-center/race-lp985756
2. cd race-lp985756
3. sudo dpkg -r 2vcard ; ./software-center search:2vcard
4. click on "install" in the list
5. wait until the progress is around the middle
6. run "dbus-send --print-reply --session --dest=com.ubuntu.Softwarecenter /com/ubuntu/Softwarecenter com.ubuntu.SoftwarecenterIFace.forceDBReopen" to simulate that update-software-center-agent finished
7. veriy that the status does no longer update

Michael Vogt (mvo) wrote :

If later the db is reopend because e.g. something else is installed the state is updated though.

Michael Vogt (mvo) on 2012-04-23
tags: added: ca-escalated
tags: removed: ca-escalated
Michael Vogt (mvo) wrote :

Adding the ca-escalted tag as this is targeted for precise-updates and has not seen any action so it needs to be evaluated on the next ca-escalated bug review.

tags: added: ca-escalated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers