submit_review_gtk3.py crashed with UnicodeDecodeError in _post_to_one_gwibber_account(): 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)

Bug #985255 reported by Thomas Wimmer on 2012-04-18
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Unassigned

Bug Description

Das Softwarecenter bricht bei einer Bewertung von Programmen ab und muss neu gestartet werden!

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Wed Apr 18 23:50:55 2012
ExecutablePath: /usr/share/software-center/submit_review_gtk3.py
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/software-center/submit_review_gtk3.py --pkgname unity-mail --iconname unity-mail --parent-xid --version 0.92.2 --origin ubuntu --datadir /usr/share/software-center/ --appname Unity\ Mail
ProcEnviron:
 LANGUAGE=de_AT:de
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/software-center/submit_review_gtk3.py', '--pkgname', 'unity-mail', '--iconname', 'unity-mail', '--parent-xid', '', '--version', '0.92.2', '--origin', 'ubuntu', '--datadir', '/usr/share/software-center/', '--appname', 'Unity Mail']
SourcePackage: software-center
Title: submit_review_gtk3.py crashed with UnicodeDecodeError in _post_to_one_gwibber_account(): 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Thomas Wimmer (netbox17) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo) on 2012-04-23
visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → precise-updates
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I think this is fixed in lp:~mvo/software-center/gwibber-utf8-lp985255, if you want to help testing, please do:
$ bzr get lp:~mvo/software-center/gwibber-utf8-lp985255
$ cd gwibber-utf8-lp985255
$ ./software-center

and repeat the steps needed to make it crash previously. It should work now.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Michael Vogt (mvo) on 2012-04-23
tags: added: ca-escalated

thx for the answer ......

Thomas Wimmer

2012/4/23 Michael Vogt <email address hidden>

> ** Tags added: ca-escalated
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/985255
>
> Title:
> submit_review_gtk3.py crashed with UnicodeDecodeError in
> _post_to_one_gwibber_account(): 'ascii' codec can't decode byte 0xc3
> in position 0: ordinal not in range(128)
>
> Status in “software-center” package in Ubuntu:
> In Progress
>
> Bug description:
> Das Softwarecenter bricht bei einer Bewertung von Programmen ab und
> muss neu gestartet werden!
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
> Uname: Linux 3.2.0-23-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.0.1-0ubuntu4
> Architecture: amd64
> CrashCounter: 1
> Date: Wed Apr 18 23:50:55 2012
> ExecutablePath: /usr/share/software-center/submit_review_gtk3.py
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64
> (20120328)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python
> /usr/share/software-center/submit_review_gtk3.py --pkgname unity-mail
> --iconname unity-mail --parent-xid --version 0.92.2 --origin ubuntu
> --datadir /usr/share/software-center/ --appname Unity\ Mail
> ProcEnviron:
> LANGUAGE=de_AT:de
> PATH=(custom, no user)
> LANG=de_AT.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/share/software-center/submit_review_gtk3.py',
> '--pkgname', 'unity-mail', '--iconname', 'unity-mail', '--parent-xid', '',
> '--version', '0.92.2', '--origin', 'ubuntu', '--datadir',
> '/usr/share/software-center/', '--appname', 'Unity Mail']
> SourcePackage: software-center
> Title: submit_review_gtk3.py crashed with UnicodeDecodeError in
> _post_to_one_gwibber_account(): 'ascii' codec can't decode byte 0xc3 in
> position 0: ordinal not in range(128)
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/985255/+subscriptions
>

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed

Hello Thomas, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

Unfortunately, I am unable to reproduce the original error. However, I was able to test software-center version 5.2.1 in precise-proposed and can verify that this fix causes no regressions or other problems. To test this area, open Software Center and navigate to the details page for an installed app, and write a review. Check the checkbox for sharing to Twitter to test this specific code.

Many thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.1

---------------
software-center (5.2.1) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp977179:
    - make the review UI react correctly to conditions of network
      availability (LP: #977179)
  * lp:~mvo/software-center/fix-crash-deb-file-size-calc:
    - fix crash when installing a deb file that is not found in
      the current apt cache
  * lp:~mvo/software-center/lp981992:
    - fix a crash in the new a11y code if there is a row that has
      no data or is not yet preloaded (LP: #981992)
  * lp:~mvo/software-center/fix-gmenu-searcher:
    - fix the menu searcher for non-Unity configurations after
      the app-install-data-ubuntu file layout changed
  * lp:~mvo/software-center/lp808455:
    - trivial fix for crash on downstream distros (LP: #808455)
  * lp:~mvo/software-center/lp927262:
    - fix crash when get_vadjustment() returns None (LP: #927262)
  * lp:~mvo/software-center/utf8-fixes:
    - fix various utf8-related crashes (LP: #943500, LP: #922225,
      LP: #917755)
  * lp:~mvo/software-center/gwibber-utf8-lp985255:
    - fix a utf8 crash in the gwibber integration (LP: #985255)
  * lp:~mvo/software-center/workaround-gtk-regression-lp986186:
    - workaround performance issue with the Gtk.TreeView.set_model()
      call when there is a cell_data_func attached. Not every user is
      affected (settings dependant somehow), but when affected it causes
      a massive performance degration for huge list models like "System"
      (LP: #986186). This branch works around the problem by disconnecting
      the cell_data_func before setting the new model.
  * lp:~mvo/software-center/fix-clear-credentials-race:
    - fix an incorrect use of the sso dbus backend, we now correctly
      wait until it emits a CredentialsCleared signal (LP: #986117)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/add-to-launcher-after-auth-lp972710:
    - fix bug where an application will be added to the Unity launcher
      in the case where the user cancels the installation auth dialog
      (LP: #972710)
  * lp:~gary-lasker/software-center/recommendations-sso-login-lp973612:
    - fix bug where the recommendations opt-in panel is hidden if
      the user declines the SSO dialog after opting in (LP: #973612)
    - fix the user experience if the user has previously opted-in to
      recommendations and their SSO token is found have been removed
      or revoked or otherwise found to be invalid (LP: #967064)
    - improve the responsiveness of the spinner in the recommendations
      flow
 -- Michael Vogt <email address hidden> Thu, 26 Apr 2012 09:47:19 +0200

Changed in software-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers