'Sync Between Computers' no longer working after checking package details

Bug #981536 reported by iGadget on 2012-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

The awesome 'Sync Between Computers' feature stops working after viewing the details ('More Info') of any package which is installed on another synced computer.

Steps to reproduce:
1. Have at least one other machine to sync from, then start SC
2. Navigate to upper left corner
3. Click 'File'
4. Choose 'Sync Between Computers...'
5. Select the machine you want to sync from
6. Select any package in the list of items which are not on your machine
7. Click 'More Info'
8. Now try to get back to the list of packages, i.e. by clicking the left arrow / back button.
Notice that nothing happens.
9. Click on the left arrow / back button again
You are now back at the main screen of SC.
10. Try getting back to the list, i.e. by repeating steps 2-4
Notice that nothing happens.

The only way to get back to get this working again is to restart SC.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Sat Apr 14 13:47:38 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

iGadget (igadget) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can not reproduce this (fully at least). When I click "back" I get a spinner and it takes a long time (20-30sec) until the tree
is availalbe again. But eventually it does become available. Its pretty slow (and undeeded though).

If you have time it would be great if you could test:
$ bzr get lp:~mvo/software-center/oneconf-lp981536
$ cd oneconf-lp981536
$ ./software-center
(first run will take a bit, second will be quick)

and see if that fixes the issue, ideally with more than 1 additional machines.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers