software-center crashed with AttributeError in _app_activated_cb(): 'NoneType' object has no attribute 'get_pkgname'

Bug #969907 reported by jaymit on 2012-03-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker
Precise
High
Gary Lasker

Bug Description

[TEST CASE]
Unfortunately, this is a crash for which reliable steps to reproduce are not known. However, the fix removes the mechanism that can result in the crash, and so simply checking for regressions (and that the crash described in the test case never occurs) will be most useful and will be sufficient.

Regression testing should focus on the various listviews, that is, to click both the "More Info" and the "Install/Remove" buttons in the listviews for both the "All Software" and "Installed" views (the latter tests the treeview case).

[REGRESSION POTENTIAL]
Risk of regression is very low, but if something were to manifest it would likely be noticeable as an anomoly when viewing and browsing the various list views described above. Also, please report any exception if one is reported.

---

Newly installed OS with latest updates 31/03/12 10.30am (64-bit). Crash on removing games

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.14
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Sat Mar 31 10:44:52 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: This
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _app_activated_cb(): 'NoneType' object has no attribute 'get_pkgname'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

jaymit (jaymit) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo) wrote :

This is a pretty common error according to errors.ubuntu.com so we need to SRU a fix.

visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → precise-updates
tags: added: ca-escalated
Changed in software-center (Ubuntu):
importance: Medium → High
tags: removed: ca-escalated

System launched an auto-report whilst I was using the Software Centre. I was trying to uninstall more than one item at once. I really did prefer the old 'add-remove programs' where a few items could be selected for install or uninstall. The Software Centre isn't keen on doing more than one job at once.

Michael Vogt (mvo) wrote :

When I select package "software-center" in errors.ubuntu.com I still see this as ~25 crashes for today (98/day is the top bug) so this needs attention.

Michael Vogt (mvo) wrote :

At this point I'm not even sure when this function is called.

Sebastien Bacher (seb128) wrote :

This bug got a bit over 1 300 report since the start of the month on 12.04, is there any chance to get it looked at before the end of the month lts point release freeze?

Gary Lasker (gary-lasker) wrote :

Thanks seb128 for bringing this one up. I'll attach a proposed fix in a few minutes.

Thanks!
Gary

Changed in software-center (Ubuntu):
milestone: precise-updates → none
Changed in software-center (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
milestone: none → precise-updates
status: Confirmed → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Michael Vogt (mvo) on 2012-07-20
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
description: updated
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
Stéphane Graber (stgraber) wrote :

Reverting the precise task to In Porogress, Fix Commited is for packages that are in the -proposed pocket, this package is still in the Unapproved queue.

Changed in software-center (Ubuntu Precise):
status: Fix Committed → In Progress

Hello jaymit, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.5 in precise-proposed does not cause any regressions per the test details given in the description.

Thanks!

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.5

---------------
software-center (5.2.5) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-lp1009039:
    - fix treeview selection background (LP: #1009039)
  * lp:~mvo/software-center/fix-lp1011522:
    - fix bug where clicking on "Reinstall previous purchases" twice
      shows endless spinner (LP: #1011522)
  * lp:~mvo/software-center/click_url:
    - adds support for a "click_url" from the exhibits banner to
      support banners for things like the humble-bundle where we
      don't have packages but URLs (LP: #1020205)
  * lp:~mvo/software-center/hopefully-fix-lp1008229:
    - fix crash that can happen if there is an error while
      opening a deb file (LP: #1008229)
  * lp:~mvo/software-center/lp1026494:
    - typo fix in the hw description code (LP: #1026494)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/unity-launcher-integration-fixes:
    - fix bug where for-purchase items are not being added to the Unity
      launcher (LP: #925014)
    - fix bug where the Unity launcher item for an application incorrectly
      points to its app-install-data desktop file rather than its installed
      desktop file (LP: #999427)
    - fix bug where an application's icon remains in the Unity launcher after
      the corresponding application has been uninstalled (LP: #981488)
    - fix bug where the Unity launcher fails to auto-hide after installation
      of a for-purchase item (LP: #1002440)
    - fix bug where items in the "Independent" section are not being added
      to the Unity launcher (LP: #1012877)
  * lp:~gary-lasker/software-center/tech-items-to-launcher-fix-lp1006483:
    - don't add an item to the launcher if its desktop file specifies
      NoDisplay=true (LP: #1006483)
  * lp:~gary-lasker/software-center/launcher-integration-unit-tests:
   - additional unit tests to round out the suite for the Unity
     launcher integration feature
  * lp:~gary-lasker/software-center/fix-lp969907-for-5.2:
    - fix race condition in _app_activated_cb() (LP: #969907)
 -- Michael Vogt <email address hidden> Mon, 23 Jul 2012 16:38:04 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers