software-center crashed with AttributeError in _save_treeview_state(): 'NoneType' object has no attribute 'get_value'

Bug #969737 reported by Bob Merhebi on 2012-03-31
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Used the software center to install the "Ubuntu Restricted Extras" after which I closed it & it crashed!

lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.14
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0-0ubuntu1
Architecture: amd64
Date: Sat Mar 31 04:42:11 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _save_treeview_state(): 'NoneType' object has no attribute 'get_value'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Bob Merhebi (bobmerhebi) wrote :
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.14.2

---------------
software-center (5.1.14.2) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/config-tweak:
    - cleanup concerning always having a 'general' section in the cfg file
  * lp:~mvo/software-center/pygi-properties-fixes:
    - properly initialize the properties in CellRendererAppView as required
      for pygi, fixes crash on network events (LP: #965937)
  * lp:~mvo/software-center/lp977889:
    - fix the disappearing list view sort combobox (LP: #977889)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/recommends-more-button-lp971567:
    - correctly render 'more' button in recommendations panel (LP: #971567)
  * lp:~gary-lasker/software-center/show-technical-items-lp955030:
    - make 'show n technical items' appear clickable again (LP: #955030)
  * lp:~gary-lasker/software-center/fix-crash-lp969737:
    - fix an intermittent crash that can occur when saving the vertical
      position of the installed pane treeview on a cache refresh
      (LP: #969737)
  * lp:~gary-lasker/software-center/fix-crash-lp970157:
    - Small fix for a crash that can happen during the installed view
      treeview initialization (LP: #970157)
  * lp:~gary-lasker/software-center/fix-crash-lp968988:
    - Fix crash bug LP: #968988 by making sure that there is always
      a tree_view.selected_row_renderer
  * lp:~gary-lasker/software-center/remember-sort-preference-lp966878:
    - Fix for bug LP: #966878 to not reset the user's sorting preference
      if they have set one

  [ Nekhelesh Ramananthan ]
  * lp:~nik90/software-center/add_keywords_new:
    - added keywords to the desktop file for better search criteria
      (LP: #977175)

  [ Sebastian Heinlein ]
  * lp:~glatzor/software-center/fix-977020:
    - fix software-center error dialogs for errors other than
      ERROR_INVALID_PACKAGE_FILE and ERROR_UNAUTHENTICATED_PACKAGE
      (LP: #977020)
    - Allow to repair an incomplete installation (partially fixes
      LP: #659438)

  [ Kiwinote ]
  * lp:~kiwinote/software-center/lp951557:
    - don't duplicate text on paste (LP: #951557)
 -- Michael Vogt <email address hidden> Tue, 10 Apr 2012 19:21:21 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers