software-center crashed with TypeError in on_image_download_complete(): <AppTreeStore object at 0x6075140 (softwarecenter+ui+gtk3+models+appstore2+AppTreeStore at 0x6813d30)>: unknown signal name: needs-refresh

Bug #969732 reported by Brendan Heussler on 2012-03-31
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker
Precise
High
Gary Lasker

Bug Description

Ubuntu Software Center version 5.2, Precise Pangolin

Steps to reproduce:

1. Have one or more purchased items installed (items priced at $0 will work fine).
2. Open a terminal and type the following to clear your Software Center icon cache:
  $ cd ~/.cache/software-center/icons
  $ rm *
3. Launch the Ubuntu Software Center.
4. Select menu item "File"->"Sync Between Computers".
5. In the list view that is shown, expand one of the categories that includes one of your purchased items (generally, "Games" will work).

What happens:
Software Center crashes with a TypeError per the stacktrace shown in the attached Traceback.txt.

What should happen:
Umm, no crash!

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.14
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu1
Architecture: amd64
Date: Fri Mar 30 21:32:16 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with TypeError in on_image_download_complete(): <AppTreeStore object at 0x6075140 (softwarecenter+ui+gtk3+models+appstore2+AppTreeStore at 0x6813d30)>: unknown signal name: needs-refresh
UpgradeStatus: Upgraded to precise on 2012-03-10 (20 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare wireshark

Related branches

Brendan Heussler (beedaan) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
iGadget (igadget) wrote :

It crashed (several times already, not just with this particular flow) when using the awesome 'Sync between computers' feature and waiting for the list of apps of the computer I was comparing to, to be refreshed (it seems to auto-refresh every minute or so which is pretty irritating).

iGadget (igadget) wrote :

And I just got this on another machine as well (with updates applied on April 14), using the same steps.

iGadget (igadget) wrote :

Same bug, third machine.

Abelardo Diaz (werever) wrote :

after updates april 19...still crashes and automatically bring me to this bug

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
description: updated
Changed in software-center (Ubuntu):
milestone: none → precise-updates
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
milestone: none → precise-updates
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
assignee: nobody → Gary Lasker (gary-lasker)
Steve Langasek (vorlon) wrote :

I notice this bug is now the top crasher on errors.ubuntu.com. Is any sponsorship needed to get the fix landed in quantal/precise?

tags: added: ca-escalated
Gary Lasker (gary-lasker) wrote :

Hi Steve. This fix for this one went out to SRU yesterday for Precise with software-center version 5.2.2, and will be included in our first release for Quantal which should be very soon I expect.

Thanks!

Michael Vogt (mvo) wrote :

Hi Steve, once this goes in as a SRU into precise-proposed it should be copied into quantal too.

On Wed, May 16, 2012 at 02:05:54PM -0000, Michael Vogt wrote:
> Hi Steve, once this goes in as a SRU into precise-proposed it should be
> copied into quantal too.

Yep, noted. We are trying to be more strict about not doing copies from
-proposed to the devel release - it's ok in this case because
software-center is pure python and there's no new version of python in
quantal, but going forward please do separate uploads to precise-proposed
and quantal.

Hello Brendan, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package software-center - 5.2.2

---------------
software-center (5.2.2) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/whatsnew-leak-lp985389:
    - search filter fix for the case when the "installed-only"
      filter leaks into subsequent searches (LP: #985389)
  * lp:~mvo/software-center/fix-lp994632:
    - add a dep to ensure we get the correct ubuntu-sso-client-gtk
      (LP: #994632)
  * lp:~mvo/software-center/proper-error-on-unknown-files:
    - show a proper error message when attempting to open unknown
      file types (LP: #944868)
  * lp:~mvo/software-center/lp921799:
    - fix crash when decoding screenshots JSON (LP: #921799)
  * lp:~mvo/software-center/lp959612:
    - fix crash when selecting the Installed view very quickly
      after startup (LP: #959612)

  [ Ken VanDine ]
  * lp:~ken-vandine/software-center/lp_982567:
    - Check if the proxy is enabled, if the proxy host is set but not
      enabled we shouldn't attempt to use the proxy (LP: #982567)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp969732:
    - need to explicitly declare the needs-refresh signal in the
      AppTreeStore class to prevent a crash (LP: #969732)
  * lp:~gary-lasker/software-center/fix-crash-lp870822:
    - don't crash if we don't get a pkgversion object back
      (LP: #870822)
  * lp:~gary-lasker/software-center/fix-shutdown-crash-lp996333:
    - never crash when writing out the software center config file on
      shutdown (LP: #996333)
  * lp:~gary-lasker/software-center/fix-makedirs-race-crashes:
    - fix crash on race when creating the cache or config directories
      (LP: #743003, LP: #621182)
  * lp:~gary-lasker/software-center/fix-crash_lp973379:
    - ensure that the cache is ready before using the recommender
      service (LP: #973379 )
  * lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup:
    - set the toolbar buttons insensitive for the duration of time that the
      lobby panels are initializing (LP: #999486, LP: #994341)

  [ Robert Roth ]
  * lp:~evfool/software-center/bug532072:
    - escape markup for support info and license (LP: #993279)
    - ellipsize summary at trailing end (LP: #532072)
  * lp:~evfool/software-center/lp626037:
    - subtle background color tweak for consistency
      between views (LP: #626037)
  * lp:~evfool/software-center/lp835005:
    - no need for the software-properties dialog to be modal
      to software-center (LP: #835005)
  * lp:~evfool/software-center/lp839389:
    - don't display an "icon not found" image in the Unity
      launcher when a report a review window is opened (LP: #839389)
  * lp:~evfool/software-center/867588:
    - capitalize the first letter of the package summary
      (LP: #867588)
  * lp:~evfool/software-center/lp876657:
    - make sure the search field does not disappear when an
      install or remove is in progress (LP: #876657)
  * lp:~evfool/software-center/lp987797:
    - fix alignment in the reviews part of the appdetails (LP: #987797)
  * lp:~evfool/software-center/lp844768:
    - show a indeterminate progress bar when software-center waits for
      another ...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.2 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package software-center - 5.2.2

---------------
software-center (5.2.2) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/whatsnew-leak-lp985389:
    - search filter fix for the case when the "installed-only"
      filter leaks into subsequent searches (LP: #985389)
  * lp:~mvo/software-center/fix-lp994632:
    - add a dep to ensure we get the correct ubuntu-sso-client-gtk
      (LP: #994632)
  * lp:~mvo/software-center/proper-error-on-unknown-files:
    - show a proper error message when attempting to open unknown
      file types (LP: #944868)
  * lp:~mvo/software-center/lp921799:
    - fix crash when decoding screenshots JSON (LP: #921799)
  * lp:~mvo/software-center/lp959612:
    - fix crash when selecting the Installed view very quickly
      after startup (LP: #959612)

  [ Ken VanDine ]
  * lp:~ken-vandine/software-center/lp_982567:
    - Check if the proxy is enabled, if the proxy host is set but not
      enabled we shouldn't attempt to use the proxy (LP: #982567)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp969732:
    - need to explicitly declare the needs-refresh signal in the
      AppTreeStore class to prevent a crash (LP: #969732)
  * lp:~gary-lasker/software-center/fix-crash-lp870822:
    - don't crash if we don't get a pkgversion object back
      (LP: #870822)
  * lp:~gary-lasker/software-center/fix-shutdown-crash-lp996333:
    - never crash when writing out the software center config file on
      shutdown (LP: #996333)
  * lp:~gary-lasker/software-center/fix-makedirs-race-crashes:
    - fix crash on race when creating the cache or config directories
      (LP: #743003, LP: #621182)
  * lp:~gary-lasker/software-center/fix-crash_lp973379:
    - ensure that the cache is ready before using the recommender
      service (LP: #973379 )
  * lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup:
    - set the toolbar buttons insensitive for the duration of time that the
      lobby panels are initializing (LP: #999486, LP: #994341)

  [ Robert Roth ]
  * lp:~evfool/software-center/bug532072:
    - escape markup for support info and license (LP: #993279)
    - ellipsize summary at trailing end (LP: #532072)
  * lp:~evfool/software-center/lp626037:
    - subtle background color tweak for consistency
      between views (LP: #626037)
  * lp:~evfool/software-center/lp835005:
    - no need for the software-properties dialog to be modal
      to software-center (LP: #835005)
  * lp:~evfool/software-center/lp839389:
    - don't display an "icon not found" image in the Unity
      launcher when a report a review window is opened (LP: #839389)
  * lp:~evfool/software-center/867588:
    - capitalize the first letter of the package summary
      (LP: #867588)
  * lp:~evfool/software-center/lp876657:
    - make sure the search field does not disappear when an
      install or remove is in progress (LP: #876657)
  * lp:~evfool/software-center/lp987797:
    - fix alignment in the reviews part of the appdetails (LP: #987797)
  * lp:~evfool/software-center/lp844768:
    - show a indeterminate progress bar when software-center waits for
      another ...

Read more...

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers