"Buy..." stays insensitive after declining Terms of Use

Bug #961216 reported by Matthew Paul Thomas on 2012-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Ubuntu Software Center 5.1.13.1, Ubuntu 12.04 beta 1

0. If you have ever accepted the Terms of Use previously, remove the record that you have. You can do this in a terminal with the command "rm ~/.config/software-center/softwarecenter.cfg".
1. Navigate to the screen for a purchasable item.
2. Click "Buy...".
3. In the "Terms of Use" dialog, click "Decline".
4. Click "Buy..." again.

What happens: Nothing, because the "Buy..." button is insensitive.

What should happen: The "Terms of Use" dialog reopens to let you change your mind.

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → Low
description: updated
Dave Morley (davmor2) on 2012-03-21
Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.13.2

---------------
software-center (5.1.13.2) precise; urgency=low

  [ kiwinote ]
  * looks like the latest gtk causes us to receive less style-updated
    signals, call init_sc_css_provider explicitly so we don't loose our
    custom theming (LP: #961102)

  [ Paolo Rotolo ]
  * data/ui/gtk3/SoftwareCenter.ui:
     - fix string from "Terms of Service" to "Terms of Use" (LP: #963309).

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/tos-urls-lp961538:
    - use a different url for the inline ToS dialog (LP: #961538)
  * lp:~gary-lasker/software-center/fix-crash-lp960742:
    - do not crash if file can not be unlinked (LP: #960742)
  * lp:~gary-lasker/software-center/tos_buy_button_fix_lp961216:
    - This branch fixes bug LP: #961216, where the "Buy" button on the
      details page and listview stays insensitive after declining the
      ToS dialog
  * lp:~gary-lasker/software-center/fix-crash-lp961198:
    - make recommendations menu available once the available pane is
      ready (LP: #961198)

  [ Michael Vogt ]
  * lp:~mvo/software-center/builder_get_cleanup:
    - cleaner way to get menuitems
  * lp:~mvo/software-center/lp-955346:
    - draw stars with 1px border to get crisper stars (LP: #955346)
  * lp:~mvo/software-center/fix-purchase-accept-crash:
    - fixes crash when accepting tos on system without s-c config file
  * lp:~mvo/software-center/lp962927:
    - fix race condition on creating cache dir (LP: #962927)
  * lp:~mvo/software-center/lp964918:
    - do not raise an exception in the case of multiple origins,
      instead log a warning and do the right thing in the UI
      (LP: #964918)

  [ Dave Morley ]
  * lp:~davmor2/software-center/lp965222:
    - add ldtp based statup time helper
 -- Michael Vogt <email address hidden> Mon, 26 Mar 2012 19:02:24 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers