software-center crashed with ValueError in /usr/lib/python2.7/json/__init__.py: bad marshal data (unknown type code)

Bug #958100 reported by Tigerboy on 2012-03-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Just as it states, tried to open Ubuntu Software Center repeatedly and it crashed, failing to open. This is a fresh install of Ubuntu Precise.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.12
Uname: Linux 3.2.9-030209-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sat Mar 17 12:16:55 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with ValueError in /usr/lib/python2.7/json/__init__.py: bad marshal data (unknown type code)
UpgradeStatus: Upgraded to precise on 2012-03-12 (4 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Tigerboy (tigersands) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The backtrace indicates that it fails to load the "json" module. Could you please run:
$ python -c 'import json'
on the commandline? This looks like somethng with the installation of the system went wrong
and some parts of python are not properly installed.

visibility: private → public
Changed in software-center (Ubuntu):
status: New → Incomplete
Tigerboy (tigersands) wrote :

Ran python -c 'import json' and got now output... Having too much of a problem trying to fix a package manager issue. Libc6 and it's compatriots --- absolutely will not let me update the libc6 file and I've tried every known trick to force it. So now they are broken with no way to fix. Hence I am probably going to have to do a fresh reinstall.

Launchpad Janitor (janitor) wrote :

[Expired for software-center (Ubuntu) because there has been no activity for 60 days.]

Changed in software-center (Ubuntu):
status: Incomplete → Expired
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1058884, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in software-center (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers