Number of stars is unclear

Bug #955346 reported by Greg A on 2012-03-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

I am finding that the Software Centre's display of star ratings is unclear. The filled in stars are not (at a glance) very distinguishable from the outlined stars.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.12
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 14 18:36:00 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120112)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to precise on 2012-03-10 (4 days ago)

Related branches

Greg A (etulfetulf) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Would you suggest using a different color? Maybe this needs some user testing.

Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Kiwinote (kiwinote) wrote :

It seems that there are two general issues here:
- the border of the empty stars are way too thick (if you for example look at the unicode characters ★★☆ it's directly clear which of the stars are filled and which ones aren't)
- we shouldn't display half stars - it's practically impossible to tell whether a star is a half star or a full star

(also i find that using three stars makes it so much easier to tell how many stars an application has than using five stars - ie looking at ★★☆ it's instantly clear that there are two stars, looking at ★★★★☆ it takes just that fraction longer to detect that there are four)

Greg A (etulfetulf) wrote :

I don't think the problem is with the colour, my difficulty is basically kiwinote's first point. One intentional way around the problem is simply not to display the unneeded/filler stars.

Certainly the half stars are not very clear at the moment, but if the above was addressed, I don't have any problem with them being shown.

I think five stars is fine personally.

Kiwinote (kiwinote) wrote :

the right split of this image shows what the lobby would look like if we used unicode stars instead of custom drawn ones - this could easily be implemented in the list and details views too - the submit a review dialog is probably one which we would either want to keep the custom drawing code for or we would need to do something cunning to use unicode stars there too

Matthew Paul Thomas (mpt) wrote :

If we used Unicode stars we would lose the ability to round the rating to the nearest half star, because Unicode doesn't have a half-star character.

I see two ways to make the current stars clearer: reduce the thickness of the outline, and draw unfilled stars (and the unfilled part of half-stars) in a faint grey rather than yellow. Either would help; I think both would be ideal.

The review submission dialog stars should be drawn differently anyway, to fix bug 770963.

Michael Vogt (mvo) wrote :

A small fix:

=== modified file 'softwarecenter/ui/gtk3/widgets/stars.py'
--- softwarecenter/ui/gtk3/widgets/stars.py 2012-03-19 22:05:35 +0000
+++ softwarecenter/ui/gtk3/widgets/stars.py 2012-03-22 14:28:56 +0000
@@ -84,7 +84,7 @@
 class StarRenderer(ShapeStar):

     def __init__(self):
- ShapeStar.__init__(self, 5, 0.6)
+ ShapeStar.__init__(self, 5)

         self.size = StarSize.NORMAL
         self.n_stars = 5
@@ -139,6 +139,8 @@

         cr = cairo.Context(empty_surf)
         cr.set_source(lin)
+ cr.set_line_width(1)
+
         if self.rounded:
             cr.set_line_join(cairo.LINE_CAP_ROUND)

Adolfo Jayme (fitojb) on 2012-03-26
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.13.2

---------------
software-center (5.1.13.2) precise; urgency=low

  [ kiwinote ]
  * looks like the latest gtk causes us to receive less style-updated
    signals, call init_sc_css_provider explicitly so we don't loose our
    custom theming (LP: #961102)

  [ Paolo Rotolo ]
  * data/ui/gtk3/SoftwareCenter.ui:
     - fix string from "Terms of Service" to "Terms of Use" (LP: #963309).

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/tos-urls-lp961538:
    - use a different url for the inline ToS dialog (LP: #961538)
  * lp:~gary-lasker/software-center/fix-crash-lp960742:
    - do not crash if file can not be unlinked (LP: #960742)
  * lp:~gary-lasker/software-center/tos_buy_button_fix_lp961216:
    - This branch fixes bug LP: #961216, where the "Buy" button on the
      details page and listview stays insensitive after declining the
      ToS dialog
  * lp:~gary-lasker/software-center/fix-crash-lp961198:
    - make recommendations menu available once the available pane is
      ready (LP: #961198)

  [ Michael Vogt ]
  * lp:~mvo/software-center/builder_get_cleanup:
    - cleaner way to get menuitems
  * lp:~mvo/software-center/lp-955346:
    - draw stars with 1px border to get crisper stars (LP: #955346)
  * lp:~mvo/software-center/fix-purchase-accept-crash:
    - fixes crash when accepting tos on system without s-c config file
  * lp:~mvo/software-center/lp962927:
    - fix race condition on creating cache dir (LP: #962927)
  * lp:~mvo/software-center/lp964918:
    - do not raise an exception in the case of multiple origins,
      instead log a warning and do the right thing in the UI
      (LP: #964918)

  [ Dave Morley ]
  * lp:~davmor2/software-center/lp965222:
    - add ldtp based statup time helper
 -- Michael Vogt <email address hidden> Mon, 26 Mar 2012 19:02:24 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers