software-center crashed with TypeError in function(): unknown type (null)

Bug #950899 reported by Craig Magina on 2012-03-09
152
This bug affects 33 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt

Bug Description

It crashed after I asked it to enable universe, while it was installing another application. I was also going through the "sync from other computers" software list at the time.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.12
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
Date: Fri Mar 9 10:32:10 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with TypeError in function(): unknown type (null)
UpgradeStatus: Upgraded to precise on 2012-03-09 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Craig Magina (craig.magina) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Hasan Dervish (hasan-9) wrote :

stuck in a loop. "Items can't be installed removed until package catalogue is repaired". I click repair and round I go again so I end up with several of the same "Items can't be installed removed until package catalogue is repaired" error message

Tedd Webb (teddwebb) wrote :

It crashed when I went to view the Details of an item that had been installed from a new Software Source that was not functioning properly.

I was following these instructions: http://screenlets.org/index.php/FAQ#Installation

I had added this PPA using the GUI:

deb http://ppa.launchpad.net/gilir/ubuntu gutsy main universe
deb-src http://ppa.launchpad.net/gilir/ubuntu gutsy main universe {it adds this one automatically of course}

I installed "screenlets" and configured them, but whenever I launched them, nothing happened. None of them launched. It's up and running in my "system tray" and functions fine, hasn't crashed a single time. However when I try to launch or run any one of the single "screenlets," nothing happens.

So I went back into Ubuntu Software Center as per the troubleshooting section on the web page and nothing was there. So I went to the "Installed" Section and selected "WebUpd8 repository" from the "Installed" Menu. It crashed when I went to view the "More Info" of the ONLY item listed there, "DockBar, an icon-based taskbar, dockbarx."

It was when I clicked on the "DockBar" and then clicked "More Info" that it crashed and I got this error.

I don't know if any of that helps or not, but that is step-by-step of what I was doing.

Good Luck

:)

Tedd

Nathan Hinnenkamp (nhinnenkamp) wrote :

I had the update manager open and i tried to remove a package when it crashed

Cliffm (c2mcatee) wrote :

Tried to PageUp and it crashed

Chascon (chascone) wrote :

I was flipping through Installed subcontextual menus for various PPA repos when I had this issue, Software Center crashing.

Benjamin (nailartcenter) wrote :

occured while I type the password to remove banshee

Chascon (chascone) wrote :

I also noticed that a popup reports that the program has crashed but it's up and running. Selecting the restart option simply invokes a duplicate. The app also tends to freeze and go dark fairly often over the past few days.

Michael Vogt (mvo) wrote :

I can reproduce this with the following steps:
1. open software-center
2. click on "installed" on the top toolbar
3. type "foo" in the searchbar
4. click on more info on the first item
The error appears on the terminal window.

Changed in software-center (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) on 2012-03-28
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.04
Dikay (darkknight900) wrote :

Just switched to "Installed" nothing searched just got the crash message!

Michael Vogt (mvo) wrote :

There is a additional error message here:

(software-center:8662): Gtk-CRITICAL **: gtk_tree_store_get_value: assertion `VALID_ITER (iter, tree_store)' failed

What it comes down to seems to be that the model changes so the iters are no longer valid.

Michael Vogt (mvo) wrote :

It appears that InstalledPane._row_visibility_func() is sometimes called with a iter that belongs to the self.base_model instead of the self._treefilter. Because GtkTreeIterators are only valid for the their model it errors this way. Now the challenge is to find out why this happens.

Michael Vogt (mvo) wrote :

The following diff fixes it.

=== modified file 'softwarecenter/ui/gtk3/widgets/apptreeview.py'
--- softwarecenter/ui/gtk3/widgets/apptreeview.py 2012-03-22 23:32:06 +0000
+++ softwarecenter/ui/gtk3/widgets/apptreeview.py 2012-03-29 10:01:37 +0000
@@ -504,7 +504,7 @@
             cell.set_property('isactive', False)
             i = self._needs_collapse.index(path)
             del self._needs_collapse[i]
- model.row_changed(path, it)
+ #model.row_changed(path, it)
             return

         cell.set_property('isactive', path == self.expanded_path)

Michael Vogt (mvo) on 2012-03-29
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Ravioli (ravioli) wrote :

I choose "Installed" in the Software Center and uninstalled the weather-scope (unity lens) and unity-lens-utilities when the error occured.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.14

---------------
software-center (5.1.14) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp962580:
    - add locking to the expunge helper process to fix bugs that are triggered
      if multiple expunge cache processes are run (LP: #962580)
  * lp:~mvo/software-center/cache-refresh-glitch:
    - ensure that we get a full refresh if a pkg was not available before
      show_app is called
  * lp:~mvo/software-center/lp940482:
    - fix crash if the debfile does not return proper utf8 for the
      description (LP: #940482)
  * lp:~mvo/software-center/lp966514:
    - properly handle network disconnect conditions with the Ubuntu
      SSO dialog (LP: #966514)
  * lp:~mvo/software-center/lp966879:
    - fix for crashes in the installed view treeview (LP: #966879,
      LP: #950899)
  * lp:~mvo/software-center/lp846204:
    - fix ValueError crashes in get_iter due to invalid tree paths
      (LP: #846204)
  * lp:~mvo/software-center/lp964433:
    - disconnect the model from the view before calling set_from_matches
      (LP: #964433)
  * lp:~mvo/software-center/treeview-keep-state-on-db-cache-change:
   - restore the state of the installed view treeview when the
     the db or cache changes, such as on an app install or remove
  * lp:~mvo/software-center/946393:
   - fix installing multiple apps when in a custom list view (LP: #946393)
  * lp:~mvo/software-center/lp969050:
   - disconnect the view when the model is cleared to avoid a furry of
     cursor_changed signals as the rows get removed (LP: #969050)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/installed-pane-refresh:
    - avoid rebuilding the treeview in the installedpane if its not
      required (LP: #828887)
  * lp:~gary-lasker/software-center/fix-crash-lp967036:
    - Small branch to fix a crash due to a UnicodeDecodeError when accessing
      the short description for H/W requirements (LP: #967036)
  * lp:~gary-lasker/software-center/fix-crash-lp935930:
    - fix a crash due to a UnicodeDecodeError (LP: #935930)
 -- Michael Vogt <email address hidden> Fri, 30 Mar 2012 18:00:50 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers