software-center crashed with AttributeError in install(): 'str' object has no attribute 'pkgname'

Bug #946393 reported by willy on 2012-03-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Just install some app from apt link and crash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.11
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 4 15:46:17 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120304)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center apt://apache2,apache2-doc,mysql-server,php5,libapache2-mod-php5,php5-mysql,perl,php-pear,proftpd,phpmyadmin,openssl,php5-gd,freetype2-demos,libfreetype6,libjpeg-progs,libjpeg62,libpng12-0,libgdbm3,zlib1g,expat,sablotron,libapache2-mod-php5,php5-cli,proftpd-doc,libgd-tools,libcompress-zlib-perl,libxml-dev,mingw32-binutils,webalizer,php-fpdf,ncurses-bin,libapache2-mod-perl2,libapache2-mod-perl2-doc,freetds-dev,gettext,php5-mcrypt,php5-mhash,php5-sqlite,libc-client-dev,php5-xcache
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', 'apt://apache2,apache2-doc,mysql-server,php5,libapache2-mod-php5,php5-mysql,perl,php-pear,proftpd,phpmyadmin,openssl,php5-gd,freetype2-demos,libfreetype6,libjpeg-progs,libjpeg62,libpng12-0,libgdbm3,zlib1g,expat,sablotron,libapache2-mod-php5,php5-cli,proftpd-doc,libgd-tools,libcompress-zlib-perl,libxml-dev,mingw32-binutils,webalizer,php-fpdf,ncurses-bin,libapache2-mod-perl2,libapache2-mod-perl2-doc,freetds-dev,gettext,php5-mcrypt,php5-mhash,php5-sqlite,libc-client-dev,php5-xcache']
SourcePackage: software-center
Title: software-center crashed with AttributeError in install(): 'str' object has no attribute 'pkgname'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

willy (william-lety) wrote :
tags: removed: need-duplicate-check
Kiwinote (kiwinote) wrote :

This can be reproduced by typing 'ark,apt' in the search bar and clicking the 'install 1 item' button in the action bar.

visibility: private → public
Changed in software-center (Ubuntu):
importance: Undecided → Medium
milestone: none → ubuntu-12.04-beta-2
status: New → Triaged
Michael Vogt (mvo) wrote :

From irc:

<kiwinote> mvo: completely off the top of my head iirc a few months ago the aptd.py file was updated to like application objects rather than pkgnames - i *think* this may be a case of simply updating the code for the install button in the action bar to trigger the action with a application rather than a pkgname

I think that is correct :) So hopefully the fix for tihs is straightforward.

Martin Pitt (pitti) on 2012-03-30
Changed in software-center (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Michael Vogt (mvo) on 2012-03-30
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.14

---------------
software-center (5.1.14) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp962580:
    - add locking to the expunge helper process to fix bugs that are triggered
      if multiple expunge cache processes are run (LP: #962580)
  * lp:~mvo/software-center/cache-refresh-glitch:
    - ensure that we get a full refresh if a pkg was not available before
      show_app is called
  * lp:~mvo/software-center/lp940482:
    - fix crash if the debfile does not return proper utf8 for the
      description (LP: #940482)
  * lp:~mvo/software-center/lp966514:
    - properly handle network disconnect conditions with the Ubuntu
      SSO dialog (LP: #966514)
  * lp:~mvo/software-center/lp966879:
    - fix for crashes in the installed view treeview (LP: #966879,
      LP: #950899)
  * lp:~mvo/software-center/lp846204:
    - fix ValueError crashes in get_iter due to invalid tree paths
      (LP: #846204)
  * lp:~mvo/software-center/lp964433:
    - disconnect the model from the view before calling set_from_matches
      (LP: #964433)
  * lp:~mvo/software-center/treeview-keep-state-on-db-cache-change:
   - restore the state of the installed view treeview when the
     the db or cache changes, such as on an app install or remove
  * lp:~mvo/software-center/946393:
   - fix installing multiple apps when in a custom list view (LP: #946393)
  * lp:~mvo/software-center/lp969050:
   - disconnect the view when the model is cleared to avoid a furry of
     cursor_changed signals as the rows get removed (LP: #969050)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/installed-pane-refresh:
    - avoid rebuilding the treeview in the installedpane if its not
      required (LP: #828887)
  * lp:~gary-lasker/software-center/fix-crash-lp967036:
    - Small branch to fix a crash due to a UnicodeDecodeError when accessing
      the short description for H/W requirements (LP: #967036)
  * lp:~gary-lasker/software-center/fix-crash-lp935930:
    - fix a crash due to a UnicodeDecodeError (LP: #935930)
 -- Michael Vogt <email address hidden> Fri, 30 Mar 2012 18:00:50 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers